Bug 5076 - XFree86-3.3.5-0.5.2 doesn't let non-root users run X
XFree86-3.3.5-0.5.2 doesn't let non-root users run X
Status: CLOSED DUPLICATE of bug 5001
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
Depends On:
  Show dependency treegraph
Reported: 1999-09-11 16:54 EDT by jlewis
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-09-24 15:58:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description jlewis 1999-09-11 16:54:49 EDT
On Sat, 11 Sep 1999, Jon Lewis wrote:

> I broke one of my 5.2 systems at home today to debug
this.  What I found
> is that pam support seems to have been added into
Xwrapper, and that it
> comes with an /etc/pam.d/xserver file that by default only
allows root to
> start X...and AFAICT, no instructions for changing that
behavior.  I
> messed around with /etc/pam.d/xserver and got it to allow
anyone to start
> X, but I'm not happy with the way I did it.  I don't feel
like tracking
> down the pam docs (/usr/doc/pam-0.64/ is awfully barren)
right now, so
> I'll probably look at this more tonight.

Looked at this a little more, and now I think it's
definitely a bug.  When Red Hat released XFree86-3.3.5 for
5.2 and 6.0, they included (in both
releases) pam support in Xwrapper that's been standard on
6.0 but was new to 5.2.  6.0 does come with some
documentation on console.apps and pam_console.so in
However, 5.2 knows nothing of this.  5.2 (and pam-0.64-4
which is the latest pam update for 5.2) don't have
/lib/security/pam_console.so, so the /etc/pam.d/xserver file
that comes in XFree86-3.3.5-0.5.2.i386.rpm is
Comment 1 Preston Brown 1999-09-24 15:58:59 EDT
*** This bug has been marked as a duplicate of 5001 ***

Note You need to log in before you can comment on or make changes to this bug.