Bug 50760 - ppp-watch is not necessary for demand-dial PPP links
ppp-watch is not necessary for demand-dial PPP links
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-02 17:28 EDT by Need Real Name
Modified: 2014-03-16 22:22 EDT (History)
3 users (show)

See Also:
Fixed In Version: 7.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-19 17:32:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ppp-watch Patch against ppp-watch.c of initscripts-5.83-1 (1.57 KB, patch)
2001-08-31 14:51 EDT, Need Real Name
no flags Details | Diff

  None (edit)
Description Need Real Name 2001-08-02 17:28:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
the ifup-ppp script starts ppp-watch for demand-dial links, but it is not 
necessary (and in fact it gets in the way, because ifdown-ppp kills the 
pppd process for a demand-link before killing ppp-watch, and ppp-watch 
sometimes will restart pppd)

How reproducible:
Always

Steps to Reproduce:
1.Configure ifcfg-ppp0 with DEMAND=yes
2.Execute ifup ppp0
3.Check for ppp-watch running
	

Actual Results:  it will be there :-)

Expected Results:  it shouldn't be there :-)

Additional info:

here is a patch to fix the problem (against initscripts-6.10-1):

--- ifup-ppp.orig	Thu Aug  2 14:18:35 2001
+++ ifup-ppp	Thu Aug  2 14:22:01 2001
@@ -14,8 +14,10 @@
   CONFIG=$(basename $1)
   [ -f "${CONFIG}" ] || CONFIG=ifcfg-${1}
   source_config
-  # don't start ppp-watch by xDSL
-  [ "$TYPE" = "xDSL" ] || exec /sbin/ppp-watch "${DEVICE}" "$@"
+  # don't start ppp-watch for xDSL or demand-dial connections
+  if [ ${DEMAND} != yes -a "$TYPE" != "xDSL" ] ; then
+    exec /sbin/ppp-watch "${DEVICE}" "$@"
+  fi
 fi
 
 CONFIG=$1
@@ -122,12 +124,14 @@
 
 if [ ${DEMAND} = yes ] ; then
   opts="$opts demand ktune idle ${IDLETIMEOUT} holdoff ${RETRYTIMEOUT}"
+else
+  opts="-detach $opts"
 fi
 
 (logger -p daemon.info -t ifup-ppp \
   $"pppd started for ${DEVNAME} on ${MODEMPORT} at ${LINESPEED}" &)&
 
-exec /usr/sbin/pppd -detach $opts ${MODEMPORT} ${LINESPEED} \
+exec /usr/sbin/pppd $opts ${MODEMPORT} ${LINESPEED} \
     ipparam ${DEVNAME} linkname ${DEVNAME} call ${DEVNAME}\
     noauth \
     ${PPPOPTIONS}
Comment 1 Need Real Name 2001-08-31 14:51:38 EDT
Created attachment 30394 [details]
ppp-watch Patch against ppp-watch.c of initscripts-5.83-1
Comment 2 Need Real Name 2001-08-31 15:06:34 EDT
   I have a similar problem with my 56K modem. I think the problem happens with
demand and non-on-demand links because ppp-watch fork's twice with de code of
ppp-watch.c in initscripts-5.83-1.

   After I execute:
$ date;ifup ppp0;date

   I check my logs and I see a new pppd process starts when ifup finish. So I
wrote the previous patch.
Comment 3 C.Lee Taylor 2001-12-07 04:47:37 EST
Running RedHat 7.2 with all the latest rpm's upto 07/12/2001.  This is still a
problem ... this also seems to be the same bug as 6291 and 51874.  Have taken a
look at rawhide rpms and see no change.
Comment 4 C.Lee Taylor 2001-12-07 05:54:53 EST
Okay, tried the ifup-ppp patch and basic tests find it to work.  ifup ppp0 and
ifdown ppp0 seem to do what I think is correct. Don't know if ppp-watch patch
would help, but I think the RedHat devs people will make a good choice.  Hope to
see this soon in an updated rpm.  If I find any other problems I will update the
bug.
Comment 5 Göran Uddeborg 2003-05-19 17:25:20 EDT
In 7.20-1 this seems to be fixed.  So this report can be closed now, right?
Comment 6 Bill Nottingham 2003-05-19 17:32:23 EDT
Sure.

Note You need to log in before you can comment on or make changes to this bug.