Bug 507622 - avc denied messages for logwatch when running autofs regression tests
avc denied messages for logwatch when running autofs regression tests
Status: CLOSED DUPLICATE of bug 503084
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: logwatch (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Ivana Varekova
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 10:17 EDT by Jeff Moyer
Modified: 2009-06-24 03:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 03:55:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Moyer 2009-06-23 10:17:07 EDT
Description of problem:
/sbin/ausearch -sv no -m AVC -m USER_AVC -m SELINUX_ERR -ts 6/23/2009 0:25:31
----
time->Tue Jun 23 00:26:37 2009
type=SYSCALL msg=audit(1245731197.643:35): arch=c000003e syscall=2 success=no exit=-13 a0=ba8d940 a1=241 a2=1b6 a3=2ad8c85538f0 items=0 ppid=12721 pid=12724 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="perl" exe="/usr/bin/perl" subj=system_u:system_r:logwatch_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1245731197.643:35): avc:  denied  { write } for  pid=12724 comm="perl" name="services" dev=dm-0 ino=40699022 scontext=system_u:system_r:logwatch_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_t:s0 tclass=dir

Version-Release number of selected component (if applicable):
selinux-policy  	 2.4.6  	 248.el5  	 noarch 

How reproducible:

Not 100%.  It happens at apparently random places within our tests.  See rhts jobs 67886, 67883 and 67872 for examples.
Comment 1 Daniel Walsh 2009-06-23 16:58:52 EDT
This is not an SELinux bug but a long standing error with logwatch and some other tools.
Comment 2 Ivana Varekova 2009-06-24 03:55:19 EDT

*** This bug has been marked as a duplicate of bug 503084 ***

Note You need to log in before you can comment on or make changes to this bug.