Bug 507626 - qemu-kvm VNC :: major display tearing garbage with windows guest and scrolling windows
qemu-kvm VNC :: major display tearing garbage with windows guest and scrollin...
Status: CLOSED DUPLICATE of bug 503156
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-06-23 10:33 EDT by Jonathan Underwood
Modified: 2009-07-20 04:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 04:43:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of Windows XP running in a guest (149.57 KB, image/png)
2009-06-23 10:33 EDT, Jonathan Underwood
no flags Details

  None (edit)
Description Jonathan Underwood 2009-06-23 10:33:01 EDT
Created attachment 349096 [details]
Screenshot of Windows XP running in a guest

Description of problem:
When running a (Windows XP) guest under qemu-kvm viewed using a vnc viewer it seems that the display is not updated properly when scrolling windows resulting in unreadable tearing and garbage being displayed. Screenshot attached. This is a regression from the F-10 packages where this problem was absent. I see the problem with both the vinagre and virt-manager vnc client.

Version-Release number of selected component (if applicable):
qemu-common-0.10.5-3.fc11.x86_64
qemu-system-x86-0.10.5-3.fc11.x86_64
qemu-img-0.10.5-3.fc11.x86_64

virt-manager-0.7.0-5.fc11.x86_64
libvirt-python-0.6.2-11.fc11.x86_64
libvirt-0.6.2-11.fc11.x86_64
python-virtinst-0.400.3-8.fc11.noarch

vinagre-2.26.2-1.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1.Start a windows XP guest and connect via vnc
2.Scroll an application
3.
  
Actual results:
Garbage on screen

Expected results:
No garbage on screen

Additional info:
Comment 1 Mark McLoughlin 2009-06-23 12:03:39 EDT
Thanks, I suspect this is a dup of bug #503156, but I'll leave it open until we can confirm that for sure
Comment 2 Jonathan Underwood 2009-07-13 07:15:13 EDT
Is there anything I can do to help debug this - this is a major problem, rendering guests pretty much useless for me.
Comment 3 Glauber Costa 2009-07-17 20:53:00 EDT
What I've found so far:

* It is qemu-kvm specific - does not happen with -no-kvm
* It is cirrus specific - does not happen with -vga std
* It worked until kvm-83 - stops working at kvm-84

I'll keep debugging this.
Comment 4 Mark McLoughlin 2009-07-20 04:43:13 EDT
Glauber posted a patch here:

  http://lists.gnu.org/archive/html/qemu-devel/2009-07/msg01498.html

Looks like it's confirmed as a dup of bug #503156, so marking it as such

*** This bug has been marked as a duplicate of bug 503156 ***

Note You need to log in before you can comment on or make changes to this bug.