Bug 507637 - Missing fontset info
Summary: Missing fontset info
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cjkuni-fonts
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caius Chance
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 489145
TreeView+ depends on / blocked
 
Reported: 2009-06-23 15:12 UTC by Jerry James
Modified: 2010-01-28 06:20 UTC (History)
2 users (show)

Fixed In Version: 0.2.20080216.1-26.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-28 06:20:00 UTC


Attachments (Terms of Use)

Description Jerry James 2009-06-23 15:12:59 UTC
Description of problem:
At least one Kai font is missing a fontset info field.  See bz 489145 comment #27 for a description of how this problem was tracked down.  Also, try this:

$ xlsfonts -fn "-*-*-*-*-*-*-*-*-*-*-*-*-ISO8859-13"
-misc-ar pl ukai cn-medium-r-normal--0-0-0-0-c-0-iso8859-13
-misc-ar pl ukai cn-medium-r-normal--17-120-100-100-c-0-iso8859-13
-misc-ar pl ukai hk-medium-r-normal--0-0-0-0-c-0-iso8859-13
-misc-ar pl ukai hk-medium-r-normal--17-120-100-100-c-0-iso8859-13
-misc-ar pl ukai tw mbe-medium-r-normal--0-0-0-0-c-0-iso8859-13
-misc-ar pl ukai tw mbe-medium-r-normal--17-120-100-100-c-0-iso8859-13
-misc-ar pl ukai tw-medium-r-normal--0-0-0-0-c-0-iso8859-13
-misc-ar pl ukai tw-medium-r-normal--17-120-100-100-c-0-iso8859-13
-misc-ar pl uming cn-light-r-normal--0-0-0-0-c-0-iso8859-13
-misc-ar pl uming cn-light-r-normal--17-120-100-100-c-0-iso8859-13
-misc-ar pl uming hk-light-r-normal--0-0-0-0-c-0-iso8859-13
-misc-ar pl uming hk-light-r-normal--17-120-100-100-c-0-iso8859-13
-misc-ar pl uming tw mbe-light-r-normal--0-0-0-0-c-0-iso8859-13
-misc-ar pl uming tw mbe-light-r-normal--17-120-100-100-c-0-iso8859-13
-misc-ar pl uming tw-light-r-normal--0-0-0-0-c-0-iso8859-13
-misc-ar pl uming tw-light-r-normal--17-120-100-100-c-0-iso8859-13
$ xlsfonts -l -fn "-*-*-*-*-*-*-*-*-*-*-*-*-ISO8859-13"
xlsfonts: pattern "-*-*-*-*-*-*-*-*-*-*-*-*-ISO8859-13" unmatched

The "-l" option fails because of the missing info.

Version-Release number of selected component (if applicable):
cjkuni-uming-fonts-0.2.20080216.1-23.fc11.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Use the xlsfonts commands above.
  
Actual results:
xlsfonts without "-l" lists matching font names, but xlsfonts with "-l" errors out because of the missing fontset info, causing it to print no matches.

Expected results:
"xlsfonts -l" should print information about each matching font.

Additional info:

Comment 1 Caius Chance 2009-06-23 23:49:56 UTC
http://koji.fedoraproject.org/koji/buildinfo?buildID=107011

Have you updated the cjkuni-fonts-common, cjkuni-ukai-fonts, and cjkuni-fonts-ghostscript?

ukai and any info of ukai should be not contained in cjkuni-uming-fonts package.

Comment 2 Jerry James 2009-06-25 20:50:53 UTC
I had cjkuni-fonts-common and cjkuni-uming-fonts installed.  I just installed cjkuni-fonts-ghostscript and cjkuni-ukai-fonts.  My system is fully updated as of this morning.  It makes no difference.  The xlsfonts problem reported above and the problem reported in bz #489145 still persist.

The cjkuni-fonts-common package installs /usr/share/fonts/cjkuni/fonts.{dir,scale}, both of which contain references to both the ukai and uming fonts, even if one or both is not installed.  This is how I wound up with a reference to a ukai font while only having the uming fonts installed.

Anyway, installing more fonts didn't help.

Comment 3 Caius Chance 2009-06-26 00:14:12 UTC
Okay, I should let uming and ukai in two separate dir for them to have their own font.{dir,scale} then.

I am creating a test sample rpm now.

Comment 4 Caius Chance 2009-06-26 06:38:03 UTC
I have checked the whole process of rpm installation.

I found that iso8859-13 line in font.{dir,cache} created by ttmkfdir was not correctly reflected the available encoding.

Submitted inquiry to author ArneGoetje in regard of this issue.

Comment 5 Nicolas Mailhot 2009-06-26 09:00:49 UTC
(In reply to comment #3)
> Okay, I should let uming and ukai in two separate dir for them to have their
> own font.{dir,scale} then.
> 
> I am creating a test sample rpm now.  

Please keep the packages most users will install clean. If you need some special processing for legacy core X font system, do it in a separate subpackage

(for example a -xldl subpackage that requires all the cjk*fonts packages, symlink their font files in a separate directory, and includes pre-generated or generated on install fonts.dir* files there)

Comment 6 Nicolas Mailhot 2009-06-26 09:13:34 UTC
(In reply to comment #5)
 
> (for example a -xldl subpackage

-xlfd sorry

Comment 7 Caius Chance 2009-06-28 23:34:30 UTC
I am thinking if I should apply for making cjkuni-fonts into cjkuni-uming-fonts and cjkuni-ukai-fonts as they have two separated source tarball now?

Also, the font.{dir,scale} generated are not right (missing iso8859-13). There are scale.{dir,scale} provided inside the tarballs. I am still trying to contact upstream about this issue.

Comment 9 Nicolas Mailhot 2009-06-29 07:46:50 UTC
(In reply to comment #7)
> I am thinking if I should apply for making cjkuni-fonts into cjkuni-uming-fonts
> and cjkuni-ukai-fonts as they have two separated source tarball now?

If upstream releases the fonts in separate tarballs now and if that can simplify the specs this is certainly the right thing to do (this is why guidelines recommend splitting)

Experience shows maintenance of complex multi-spec fonts is a lot more expensive than that of simple spec files.

> Also, the font.{dir,scale} generated are not right (missing iso8859-13). There
> are scale.{dir,scale} provided inside the tarballs. I am still trying to
> contact upstream about this issue.  

mkfontdir & friends have always been unreliable and broken. core fonts usage just needs to die, it is pretty much hopeless reliability-wise. Therefore it's usually a better investment to ask people who complain of core fonts brokeness to port their apps to fontconfig than try to fix a system that has been failing consistently for more than a decade

Comment 10 Jerry James 2009-06-29 15:19:49 UTC
In reply to comment #9, XEmacs has a complex redisplay engine, as well as complex rules for matching up coding systems and character sets with fonts.  Porting that (very old) redisplay engine to use fontconfig is extremely nontrivial.  Nevertheless, work has already been underway for a few years to make this happen.  It is currently suffering from a lack of knowledgeable developers to move it to completion.  Help would be gratefully accepted.

Comment 11 Jerry James 2009-07-02 19:20:26 UTC
In reply to comment #8, I manually installed those RPMs, and they fix the problem.  Thank you very much.

Comment 12 Fedora Update System 2009-07-06 04:36:37 UTC
cjkuni-fonts-0.2.20080216.1-26.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/cjkuni-fonts-0.2.20080216.1-26.fc11

Comment 13 Fedora Update System 2009-07-11 17:29:51 UTC
cjkuni-fonts-0.2.20080216.1-26.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cjkuni-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7515

Comment 14 Fedora Update System 2009-07-19 10:07:23 UTC
cjkuni-fonts-0.2.20080216.1-26.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Jerry James 2009-08-12 20:24:50 UTC
The fix that went into F-11 does not appear to have been applied to Rawhide.  We are seeing the same symptoms there, and I do not see the relevant entry in the output of "rpm -q --changelog cjkuni-uming-fonts" on Rawhide.

Comment 16 Jerry James 2009-08-31 16:25:28 UTC
Can we get the fix in Rawhide, please?

Comment 17 Jerry James 2009-09-03 14:53:35 UTC
Do you need help applying the changes to CVS?  I'm happy to do that if you'll grant permission.

Comment 18 Jerry James 2009-09-10 20:26:37 UTC
Hello?  It's been a month since I pointed out that you need to update devel, too, with no response.  Please respond.  I don't want us to have the same problems all over again in F-12.

Comment 20 Bug Zapper 2009-11-16 10:21:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 21 Caius Chance 2010-01-28 06:20:00 UTC
Fixed on rawhide (F12)


Note You need to log in before you can comment on or make changes to this bug.