Bug 507642 - youtube video download fails with "file not found" - regression from 1.2 release?
youtube video download fails with "file not found" - regression from 1.2 rele...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 11:30 EDT by Thorsten Scherf
Modified: 2009-07-16 03:16 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.0.5-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-16 03:02:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2009-06-23 11:30:00 EDT
Description of problem:
using latest miro fedora repo (Miro-2.0.4-1.fc11.i586) doesn't allow to download youtube or google videos. miro complains with "file not found". have already seen this for the 1.2 release of miro and it has been fixed at some point in time. looks like a regression.

Version-Release number of selected component (if applicable):
Miro-2.0.4-1.fc11.i586

How reproducible:
try to download youtube- or google-video

Steps to Reproduce:
1.
2.
3.
  
Actual results:
"file not found"

Expected results:
file download starts

Additional info:
Comment 1 Alex Lancaster 2009-06-29 23:59:37 EDT
Don't have an F-11 box to test on just yet.  Will try as soon as I do.

Meanwhile: Will can you reproduce this?
Comment 2 will kahn-greene 2009-06-30 09:17:22 EDT
Sorry about that.  I meant to reply to this bug last week.

We just did a Miro 2.0.5 release which fixes the YouTube download support.  YouTube changed their site around a bit and we needed to update the support to support it.  Release notes are here:

https://develop.participatoryculture.org/trac/democracy/wiki/2.0ReleaseNotes

The issue is reproducible for all Miro versions on all platforms.

One thing to note is that even though we fixed the issue, some YouTube videos still pop up a File not Found--it has to do with whether the video is embeddable or not.  We need to fix Miro so that it populates a better error message--maybe in the next version.

Hope that helps.
Comment 3 Alex Lancaster 2009-07-01 17:39:28 EDT
Thorsten: you are still listed as the primary maintainer on this package.  Do you want to continue?  If not, can you orphan the package and I can pick as the primary maintainer since I've been doing most of the updates over the last year or so.  

It would be good if you could stay as a co-maintainer.
Comment 4 Fedora Update System 2009-07-01 17:52:44 EDT
Miro-2.0.5-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/Miro-2.0.5-1.fc11
Comment 5 Fedora Update System 2009-07-01 17:59:01 EDT
Miro-2.0.5-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/Miro-2.0.5-1.fc10
Comment 6 Thorsten Scherf 2009-07-02 03:27:06 EDT
(In reply to comment #3)
> Thorsten: you are still listed as the primary maintainer on this package.  Do
> you want to continue?  If not, can you orphan the package and I can pick as the
> primary maintainer since I've been doing most of the updates over the last year
> or so.  

Alex, will definitely do that. You did a great job over the last year. Thanks for that. Will change the ownership later this day.

btw, just installed Miro-2.0.5-1.fc11.i586 which indeed fixes the youtube video download bug. Thanks.
Comment 7 Fedora Update System 2009-07-03 15:43:22 EDT
Miro-2.0.5-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-7345
Comment 8 Fedora Update System 2009-07-03 15:54:06 EDT
Miro-2.0.5-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7400
Comment 9 Fedora Update System 2009-07-16 03:02:29 EDT
Miro-2.0.5-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2009-07-16 03:16:39 EDT
Miro-2.0.5-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.