Bug 507699 - CRM 1923688 Errors while running gnome-system-monitor
CRM 1923688 Errors while running gnome-system-monitor
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libgtop2 (Show other bugs)
5.3
All Linux
urgent Severity high
: rc
: ---
Assigned To: Søren Sandmann Pedersen
Desktop QE
: Regression, ZStream
Depends On:
Blocks: 562817 847650 854013 862822 864489 866391 869122 871540 877308
  Show dependency treegraph
 
Reported: 2009-06-23 15:53 EDT by Issue Tracker
Modified: 2014-06-18 05:11 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 07:22:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch based on upstream code (4.74 KB, patch)
2009-06-23 15:59 EDT, ritz
no flags Details | Diff

  None (edit)
Description Issue Tracker 2009-06-23 15:53:11 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2009-06-23 15:53:13 EDT
Event posted on 18-06-2009 02:31pm IST by spoyarek

Description of problem:

Base OS: RHEL-5.3
Problem Component: libgtop2

Fix for the following bugzilla results in a number of warnings and incorrect values for memory utilization for processes in gnome-system-monitor:

https://bugzilla.redhat.com/show_bug.cgi?id=443749

This adds an extra entry for Swap in smaps, thus breaking the parsing logic in libgtop2.

Related upstream bug:

http://bugzilla.gnome.org/show_bug.cgi?id=518145

How reproducible:

Always.

Steps to Reproduce:

Start gnome-system-monitor from gnome-terminal

Actual results:

Warnings as seen in the attached file

Expected results:

No such warnings :)

Additional info:

Attached patch is a combination of a few patches to upstream libgtop:

http://svn.gnome.org/viewvc/libgtop/trunk/sysdeps/linux/procmap.c?r1=2598&r2=2610&view=patch
http://svn.gnome.org/viewvc/libgtop/trunk/sysdeps/linux/procmap.c?r1=2673&r2=2713&view=patch
http://svn.gnome.org/viewvc/libgtop/trunk/sysdeps/linux/glibtop_private.c?r1=2637&r2=2713&view=patch

This seems to fix the issue. I have given a test package to the customer. Will revert with his response.

Revision 2610 is not exactly relevant to this (not tested without it) but I thought it would be a good idea to get this in too :)
This event sent from IssueTracker by rkhadgar  [Support Engineering Group]
 issue 308652
Comment 2 ritz 2009-06-23 15:59:01 EDT
Created attachment 349142 [details]
patch based on upstream code
Comment 6 Chris Ward 2010-02-04 07:40:03 EST
RE: "This seems to fix the issue. I have given a test package to the customer. Will revert with his response."

Did we ever hear back from the customer on this, whether the proposed patch set fixed their issue or not?
Comment 9 Søren Sandmann Pedersen 2010-02-04 14:42:35 EST
Resetting to NEW because there is no 5.4.z flag.

Note You need to log in before you can comment on or make changes to this bug.