Bug 50772 - Add http/ftp-proxy configuration
Add http/ftp-proxy configuration
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-02 19:27 EDT by Enrico Scholz
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-02 19:27:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-08-02 19:27:42 EDT
Linux installations behind firewalls are using http/ftp-proxies to provide
controlled access to web-resources. Their address is common for all users
of a system and therefore it should be set globally.

Alas, it is not standardized how is being set. I know the following ways:

1. the http_proxy, https_proxy, ftp_proxy and no_proxy environment
variables. They could be set by /etc/bashrc or a script in /etc/profile.d. 

This scheme is used by a lot of command-line tools like lynx or wget.


2. gnome-vfs uses gconf variables. In the current gnome-vfs there are still
some discrepancies (cdda module is using settings from nautilus, other
variables under /system/gnome-vfs).

Every application using gnome-vfs would use the proxy without
user-configuration


3. kde. I am not using it, but there exists probably a mechanism like (2).


4. application specific ways like preferences.js of Netscape or the
settings in /etc/sysconfig/rhn of up2date.



I think most applications are falling into the first three categories (or
can be brought into them). Therefore it would be nice if a Red Hat
configuration tool makes this settings.
Comment 1 Trond Eivind Glomsrxd 2001-08-05 15:37:55 EDT
Don't file bugs against multiple components against a single one.

That said, for the one you filed, proxy configuration won't be added this time.
Maybe later.
Comment 2 Enrico Scholz 2001-08-06 04:01:28 EDT
This report was not against multiple components. It said proxy-configuration is
common for some classes of applications and to keep consistency, it should
happen at a central place. redhat-config-network seems to be a reasonable
central place.

Note You need to log in before you can comment on or make changes to this bug.