Bug 50775 - Installation of Fairfax Beta 3 on PE6450 exits abnormally
Summary: Installation of Fairfax Beta 3 on PE6450 exits abnormally
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.3
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-03 00:26 UTC by Tesfamariam Michael
Modified: 2005-10-31 22:00 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-09-04 20:30:29 UTC


Attachments (Terms of Use)
/proc/ide/*/model file (22 bytes, patch)
2001-08-06 19:49 UTC, Danny Trinh
no flags Details | Diff
/proc/ide/*/model file (22 bytes, text/plain)
2001-08-06 19:50 UTC, Danny Trinh
no flags Details

Description Tesfamariam Michael 2001-08-03 00:26:33 UTC
Description of Problem:
Installation of Fairfax Beta 3 from a CD terminates abnormally on 
PowerEdge 6450 with 18GB hard drive connected to onboard AIC 7899 
controller. In normal installation mode, after loading the aic7xxx, it 
terminates with: 
      failed to read /modules/module-info
      install exited abnormally
      ....
      ejecting /tmp/cdrom
Expert mode installation terminates with the same message but before 
loading any driver.
NFS install works but during driver loading, messages that go to other 
terminal gets displayed in VT1. 

How Reproducible:
always

Steps to Reproduce:
1. on PE6450, connect a SCSI hard drive to the onboard AIC7899 
2. Start installation from Fairfax Beta 3 CD
3. 

Actual Results:
Installation terminates abnormally

Expected Results:
To complete installation.

Additional Information:
There was a PERC3/DC card on the system when I first saw this issue but 
removing the PERC3/DC doesn't change anything.

Comment 1 Michael Fulbright 2001-08-03 15:47:45 UTC
Looks like a bad CD to me - have you checked the md5sum?

Comment 2 Danny Trinh 2001-08-06 17:40:17 UTC
At BOOT: prompt, I type "linux ide=nodma". The installation process going 
through. It works. Properly, this is the work around thing.

Comment 3 Bill Nottingham 2001-08-06 18:13:04 UTC
We need the contents of /proc/ide/*/model.



Comment 4 Danny Trinh 2001-08-06 19:49:43 UTC
Created attachment 26493 [details]
/proc/ide/*/model file

Comment 5 Danny Trinh 2001-08-06 19:50:39 UTC
Created attachment 26494 [details]
/proc/ide/*/model file

Comment 6 Glen Foster 2001-08-06 22:47:30 UTC
This defect is considered MUST-FIX for Fairfax

Comment 7 Matt Domsch 2001-08-07 23:52:20 UTC
More IDE CD-ROMs to blacklist.

--- linux/drivers/ide/ide-dma.c~        Tue Aug  7 10:39:28 2001
+++ linux/drivers/ide/ide-dma.c Tue Aug  7 15:06:36 2001
@@ -132,6 +132,7 @@
        { "CRD-8400B"           ,       "ALL"           },
        { "CRD-8480B",                  "ALL"           },
        { "CRD-8480C",                  "ALL"           },
+       { "CRD-8482B",                  "ALL"           },
        { "CRD-84"              ,       "ALL"           },
        { "SanDisk SDP3B"       ,       "ALL"           },
        { "SanDisk SDP3B-64"    ,       "ALL"           },
@@ -147,6 +148,8 @@
        { "WPI CDD-820",                "ALL"           },
        { "SanDisk SDP3B-64"    ,       "ALL"           },
        { "SAMSUNG CD-ROM SN-124",      "ALL"           },
+       { "SAMSUNG CD-ROM SC-148C",     "ALL"           },
+       { "SAMSUNG CD-ROM SC-148F",     "ALL"           },
        { "PLEXTOR CD-R PX-W8432T",     "ALL"           },
        { "ATAPI CD-ROM DRIVE 40X MAXIMUM",     "ALL"           },
        { 0                     ,       0               }


Comment 8 Matt Domsch 2001-08-09 15:00:37 UTC
Arjan applied patch in 2.4.7-0.12 and above.

Comment 9 Danny Trinh 2001-08-21 14:11:07 UTC
Reproduced on RC1. CD model: SMASUNG CD-ROM SN-124 . Kernel: 2.4.7-2smp

Comment 10 Danny Trinh 2001-08-21 14:11:58 UTC
Reproduced on RC1. CD model: SAMSUNG CD-ROM SN-124 . Kernel: 2.4.7-2smp


Comment 11 Arjan van de Ven 2001-08-21 14:13:40 UTC
Oh bah. Typo in the model name in the blacklist..........
fixed in the next build

Comment 12 Matt Domsch 2001-08-21 14:34:14 UTC
Arjan, there are a bunch of typos.  Look at all the SAMSUNG entries, they've 
got "CR-DROM", and I didn't catch it when pushing the new entries to Alan and 
Andre.  When they're right in your tree, can you either send the corrections to 
them, or tell me and I'll do it?
-Matt

Comment 13 Arjan van de Ven 2001-08-21 14:36:32 UTC
Yup just fixed that one.
I'll talk to Alan about it later today.

Comment 14 Arjan van de Ven 2001-08-22 07:36:12 UTC
Fixed in new build

Comment 15 Danny Trinh 2001-09-04 20:30:23 UTC
Let says:
SAMSUNG = SMASUNG CD-ROM SN-124 
TEAC = TEAC CD-ROM CD-224E
DVD = LG DVD-ROM DRN-8080B

-If I plug SAMSUNG or DVD to PE6450, RC2 fails to see RH CD1. It doesn't matter 
what option I type at the BOOT: prompt ( apic, linux ide=nodma, etc.) This 
error is the same as issue 52674
- If I plug TEAC to PE6450, It works, and I can perform the installation 
through CD
- If I plug SAMSUNG or DVD to PE2500, PE2550, and I also can install RH by CD




Note You need to log in before you can comment on or make changes to this bug.