Bug 507751 - python-magic depends on older file package.
python-magic depends on older file package.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 22:56 EDT by Dennis Payne
Modified: 2009-06-26 10:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 22:10:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Payne 2009-06-23 22:56:31 EDT
Description of problem: python-magic depends on file=5.03-1.fc11 but file-5.03-2.fc11 is installed.  mingw32-gcc-c++ fails to install.


Version-Release number of selected component (if applicable): python-magic-5.03-1.fc11


How reproducible: Try to install python-magic or mingw-gcc-c++.


Steps to Reproduce:
1. yum install python-magic
  
Actual results:
python-magic-5.03-1.fc11.i586 from fedora has depsolving problems
  --> Missing Dependency: file = 5.03-1.fc11 is needed by package python-magic-5.03-1.fc11.i586 (fedora)
Error: Missing Dependency: file = 5.03-1.fc11 is needed by package python-magic-5.03-1.fc11.i586 (fedora)


Expected results: Success


Additional info:
Comment 1 Richard W.M. Jones 2009-06-24 03:30:45 EDT
I fail to see what this bug has got to do with mingw32-gcc.
Comment 2 Dennis Payne 2009-06-24 09:03:13 EDT
python-magic is a dependency of mingw32-gcc-c++ (or one of it's dependency).  There isn't a component selection of python-magic.  I figured since I encountered the problem trying to install mingw32-gcc-g++ I'd file the bug under that component.
Comment 3 Richard W.M. Jones 2009-06-24 10:06:42 EDT
I've no idea what 'python-magic' is but it doesn't have
anything to do with mingw32-gcc.  Reassigning to Python.
Comment 4 James Antill 2009-06-24 11:20:01 EDT
Thanks richard, obviously everything with python in the name is all in one giant package ... rpm -qi python-magic, who needs/uses that.
Comment 5 Richard W.M. Jones 2009-06-24 11:26:42 EDT
To be fair here, I did look for a BZ component called
python-magic ...
Comment 6 Daniel Novotny 2009-06-24 11:35:15 EDT
hello,
the dependency for python-magic is right;
from file.spec:

%package -n python-magic
Summary: Python bindings for the libmagic API
Group:   Development/Libraries
BuildRequires: python-devel
Requires: %{name} = %{version}-%{release}

so it requires the same version and release of "file", which is its parent
package.

I tried to install python-magic now and it correctly downloaded and installed
python-magic-5.03-2

maybe there was some glitch in the repositories, which made file-5.03-2
available but python-magic-5.03-2 not, although they were built at the same
time

please try "yum clean all" and then "yum install"...
Comment 7 Dennis Payne 2009-06-24 22:10:57 EDT
"yum clean all" and then "yum install" fixed it.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.