Bug 507764 - Boot error messages caused by /etc/profile.d/lang.sh about locale set
Boot error messages caused by /etc/profile.d/lang.sh about locale set
Status: CLOSED DUPLICATE of bug 482888
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 02:13 EDT by Panos Kavalagios
Modified: 2014-03-16 23:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 10:32:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panos Kavalagios 2009-06-24 02:13:33 EDT
Description of problem: When booting the system it produces the following error messages:

/etc/profile.d/lang.sh: line 19: warning: setlocale: LC_CTYPE: cannot change locale (en_US.UTF-8): No such file or directory
/etc/profile.d/lang.sh: line 20: warning: setlocale: LC_COLLATE: cannot change locale (en_US.UTF-8): No such file or directory
/etc/profile.d/lang.sh: line 23: warning: setlocale: LC_MESSAGES: cannot change locale (en_US.UTF-8): No such file or directory
/etc/profile.d/lang.sh: line 26: warning: setlocale: LC_NUMERIC: cannot change locale (en_US.UTF-8): No such file or directory
/etc/profile.d/lang.sh: line 29: warning: setlocale: LC_TIME: cannot change locale (en_US.UTF-8): No such file or directory

caught also by /var/log/boot.log.


Version-Release number of selected component (if applicable): initscripts-8.95-1.x86_64


How reproducible: Just boot your system


Steps to Reproduce:
1. Start your F11 system
2.
3.
  
Actual results: Error messages about setting locale


Expected results: No error message should be displayed.


Additional info: It might be related that /usr filesystem is not yet mounted and locale information of /usr/share/i18n is missing at this very early stage of booting.
Comment 1 iarly selbir 2009-06-24 10:25:18 EDT
I can't reproduce this messages on my box ( x86 ).

Assigning it.

Thanks for your report


--
Fedora Triage Team Volunteer Member
Comment 2 Bill Nottingham 2009-06-24 10:32:26 EDT

*** This bug has been marked as a duplicate of bug 482888 ***

Note You need to log in before you can comment on or make changes to this bug.