Bug 507783 - Audacious fails to reinitialize itself when starting a new song in the playlist
Audacious fails to reinitialize itself when starting a new song in the playlist
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: audacious-plugins (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael Schwendt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 04:27 EDT by Jochen Wiedmann
Modified: 2009-07-30 06:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-30 06:26:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pstack trace of hung audacious process (5.00 KB, text/plain)
2009-07-18 18:51 EDT, Chris Rankin
no flags Details
pstack trace of hung audacious process, with debuginfo (5.47 KB, text/plain)
2009-07-18 19:09 EDT, Chris Rankin
no flags Details

  None (edit)
Description Jochen Wiedmann 2009-06-24 04:27:17 EDT
Description of problem:

I am usually using Audacious to play along a playlist with several hundred songs. After playing some songs, Audacious has problems when skipping to the next song. The next song appears properly on the display, but it isn't played at all or it is played with interruptions, intermittent noise or whatever. I typically fix this problem by rewinding to the previous song and skipping forward to the next song again: Now the same song is played without any problems.

The problem is not related to any particular file format: I notice it with both mp3 and ogg files, so its likely not the codec.

Rhythmbox doesn't have the same problem. I also didn't have this problem with Fedora 10. Finally, I have tried to upgrade to Audacious 2, using the SRPMS from http://mschwendt.fedorapeople.org/audacious-2.0.1-0.1.fc10.src.rpm
They suffer from the same problem.

Version-Release number of selected component (if applicable):

1.5.1-7.fc11

How reproducible:

Likelyhood 80-90%

Steps to Reproduce:
1. Open Audacious
2. Load a playlist
3. Start playing a song from the playlist and wait for the 10th or 15th song.
  
Actual results:

At some point, new songs aren't played, or are played with interruptions or intermittent noise.

Expected results:

Songs are played just fine, thank you!

Additional info:

No apparently related messages appear on the command line. I only notice

  (audacious:7906): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display:
    assertion `atom != GDK_NONE' failed
Comment 1 Michael Schwendt 2009-06-27 03:56:42 EDT
What audio output plugin inside Audacious do you use? ALSA or PulseAudio?
Comment 2 Jochen Wiedmann 2009-06-27 06:22:12 EDT
According to Preferences / Audio / Current output plugin its ALSA. I'll change that to Pulseaudio and try whether it changes anything. Will report the results next week or so.
Comment 3 Michael Schwendt 2009-06-30 12:22:09 EDT
Also be sure to update to at least audacious-plugins-1.5.1-6.fc11, as the audio output driver is stored in the plugins package:
https://admin.fedoraproject.org/updates/F11/FEDORA-2009-6438

And note the fresh test-update that contains the brand-new "alsa-ng" plugin:
https://admin.fedoraproject.org/updates/audacious-plugins-1.5.1-9.fc11
Comment 4 Chris Rankin 2009-07-18 09:49:10 EDT
I am seeing somthing similar, also with audacious-1.5.1-9.fc11.i586, audacious-plugins-1.5.1-6.fc11.i586. However, in my case, audacious plays a single track and then freezes when it tries to play a second track.

My output plugin is ALSA, with a buffer size of 500 and outputting to the default device (PulseAudio).

Mixer card: SB Audigy 2 ZS [SB0353]
Mixer device: PCM

Using audacious's PulseAudio plugin avoids the problem.
Comment 5 Chris Rankin 2009-07-18 18:51:01 EDT
Created attachment 354260 [details]
pstack trace of hung audacious process

> Using audacious's PulseAudio plugin avoids the problem.  

I have just tried this work-around on a 500 MHz P3 machine, and pulseaudio's CPU usage was > 60%; the machine was effectively rendered incapable of multitasking. With the ALSA plugin instead (pulseaudio as the default ALSA device), pulseaudio's CPU usage was about 6%. This machine used a SB Live! card.

So basically, I'd much prefer to use audacious's ALSA plugin. To that end, I am attaching a pstack trace of a hung audacious process.
Comment 6 Chris Rankin 2009-07-18 19:09:41 EDT
Created attachment 354261 [details]
pstack trace of hung audacious process, with debuginfo

The pstack trace is probably more useful with audacious's debuginfo packages loaded!
Comment 7 Michael Schwendt 2009-07-19 03:56:02 EDT
Chris, it's better to open a separate ticket, or else you're disturbing the NEEDINFO communication with the original reporter.

Also, please upgrade to audacious-plugins-1.5.1-10.fc11 from updates-testing:
https://admin.fedoraproject.org/updates/F11/FEDORA-2009-7405

There is at least one deadlock condition in Audacious 1.5.1 up to 2.1, and for one backtrace I've made, two main threads don't return from poll():
https://www.redhat.com/archives/fedora-devel-list/2009-July/msg00554.html
Comment 8 Michael Schwendt 2009-07-30 06:26:54 EDT
kernel-2.6.29.6-213.fc11 significantly improves ALSA and PulseAudio playback for me and also fixes the deadlocks, but according to rumours it may need another kernel update for further ALSA fixes.

Closing this ticket, as it's been sitting in NEEDINFO for a month.

Note You need to log in before you can comment on or make changes to this bug.