Bug 507789 - Slaves specified in rhn_server_iss.conf still not able to sync channels
Slaves specified in rhn_server_iss.conf still not able to sync channels
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
530
All Linux
low Severity low
: ---
: ---
Assigned To: Pradeep Kilambi
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 05:50 EDT by Garik Khachikyan
Modified: 2015-01-04 16:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 07:46:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2009-06-24 05:50:12 EDT
Description of problem:
Referring to Install Guide there should be configured a server property "allowed_iss_slaves" in a file *"/etc/rhn/default/rhn_server_iss.conf"* containing the slaves list synchronizing by ISS from this server. Then restart of httpd needed.
But doing this does not help as slaves still not able to, for example, list the server's channel list. and only adding the slave to the /etc/rhn/rhn.conf helps.


Version-Release number of selected component (if applicable):
20090623.0

How reproducible:
always.

Steps to Reproduce:
1. Take a slave which has the same Satellite 5.3.0 version than your server.
2. Modify server property file /etc/rhn/default/rhn_server_iss.conf and apply the slave url in the "allowed_iss_slaves" property.
3. Do service httpd restart
4. Use ISS on slave side - e.g. try to retrieve channels list.
  
Actual results:
Error returns:
--
ERROR: The Server listed within iss-parent is not configured for ISS 
       capability.
       Please review your configuration before trying again.
--

Expected results:
The channel list of server should be retrieved.

Additional info:
Comment 1 Pradeep Kilambi 2009-06-24 07:46:51 EDT
thats because you're editing the wrong config file. You should be first looking in /etc/rhn/rhn.conf which takes precedence over any defaults configs. 

Please read the white paper if you're unsure how to use the feature,

http://wiki.rhndev.redhat.com/wiki/ISS_Best_Practices

Note You need to log in before you can comment on or make changes to this bug.