Bug 507793 - S-c-tools cleanup: language support is installed check suggestion
S-c-tools cleanup: language support is installed check suggestion
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Naveen Kumar
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: 493604
  Show dependency treegraph
 
Reported: 2009-06-24 06:16 EDT by Jaroslav Reznik
Modified: 2010-08-03 06:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 06:20:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2009-06-24 06:16:36 EDT
Description of problem: there's no way for user to check if desired language support is already installed or it has to be installed (that could be problem while offline etc.).

system-config-language-1.3.2-5.fc11.noarch

Steps to Reproduce:
1. run s-c-language 

Actual results:
No "installed" flag in the list of languages.

Expected results:
"Installed" flag in the list.

Additional info:
This bug report is part of "System Configuration Tools Cleanup Project". Don't
hesitate to ask project maintainers for any kind of help.
Comment 1 Bug Zapper 2009-11-16 05:23:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Naveen Kumar 2010-08-03 05:53:09 EDT
IMHO this is not a bug because there is a considerable overlap with yum package. Consider this scenario:

1. I install a language XYZ support using s-c-l
2. s-c-l marks a visible flag (e.g. checkbox) in s-c-l for this language XYZ
3. Now using console I remove this language XYZ support (e.g. yum remove @XYZ-support)

Now, until unless yum decides to notify s-c-l about this change, in some way, there is no way to keep track of already installed languages. 

Otherwise every time s-c-l starts, it would have to probe/read yum database to decide which language support is installed. This is a kind of overhead for s-c-l every time it starts.

Until there is an event request-notify kind of architecture (or request broker architecture as in CORBA or maybe Dbus) in place, yum will not go on notifying applications, about package changes.

What say you?
Comment 3 Pravin Satpute 2010-08-03 06:20:46 EDT
yes agree with you naveen

1) this is really out of the scope of the s-c-l

2) even yum also not maintaining list of installed group, 

3) if there is any central place where we are keeping this info updated (i.e
manual install/uninstall by user and installed group) then s-c-l can pull that
information while running, but AFAIK there is no such present thing

that's why closing this as a not a bug

it will be nice if we can get such utility from yum.

please reopen if any problem

Note You need to log in before you can comment on or make changes to this bug.