Bug 507798 - missing link for glibc-common-2.5-34
missing link for glibc-common-2.5-34
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gcc (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Dennis Gregorovic
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 06:56 EDT by masanari iida
Modified: 2009-11-26 09:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-26 09:01:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description masanari iida 2009-06-24 06:56:26 EDT
Description of problem:
When I try to download debuginfo RPM of glibc-common-2.5-34.i386.rpm 
the file is missing.

Version-Release number of selected component (if applicable):
debuginfo for glibc-common-2.5-34.i386.rpm on RHN.

How reproducible:
always

Steps to Reproduce:
1. Open glibc-common-2.5-34.i386.rpm page on RHN.
https://rhn.redhat.com/rhn/software/packages/details/Overview.do?pid=468366

2. Click "Associated Debug Info Package(s)"

  
Actual results:
The link is
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/i386/Debuginfo/glibc-common-debuginfo-2.5-34.i386.rpm
This file is missing.

Additional info:
If I specify the file name glibc-debuginfo-common-2.5-34.i386.rpm,
the file does exist.
And it seemed the file name "glibc-debuginfo-common" is correct,
because if I wanted to install glibc-debuginfo RPM, then RPM 
request me to add dependency RPM file "glibc-debuginfo-common".

# rpm -qa --last |more
glibc-debuginfo-2.5-34                        Wed Jun 24 19:15:05 2009
glibc-debuginfo-common-2.5-34                 Wed Jun 24 19:15:02 2009

I hope RH will correct missing link on RHN,
in order to download the debuginfo file.
Comment 1 David Lawrence 2009-06-24 23:41:00 EDT
This is not a Bugzilla code bug itself so reassigning to different product and component so the proper people will see this issue.
Comment 2 Stephen Herr 2009-07-24 16:06:38 EDT
Redirecting to proper party...
Comment 3 Dennis Gregorovic 2009-07-24 18:05:37 EDT
The correct URLs are:

ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/i386/Debuginfo/glibc-debuginfo-2.5-34.i386.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/i386/Debuginfo/glibc-debuginfo-common-2.5-34.i386.rpm

If you have the yum-utils package installed, you can install the debuginfo packages with the following command:

debuginfo-install --enablerepo rhel-debuginfo glibc
Comment 5 Tomas Kopecek 2009-11-26 09:01:31 EST
Closing as WONTFIX. glibc-debuginfo-common is a special case, so rhn cannot determine correct ftp path.

Note You need to log in before you can comment on or make changes to this bug.