Bug 507867 - Satellite-Sync is not kicking off repo generation
Satellite-Sync is not kicking off repo generation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Devan Goodwin
na
:
Depends On:
Blocks: 485807 486216
  Show dependency treegraph
 
Reported: 2009-06-24 11:23 EDT by wes hayutin
Modified: 2009-09-10 14:16 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:16:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-06-24 11:23:36 EDT
Description of problem:

sat530 6/19 build rhel 5 selinux enforcing

After a fresh install of satellite and satellite-syncing there is no data in 
/var/cache/rhn/repodata


only when you register a client, does the repo generation begin.

working w/ prad on the issue, not sure how much there is to document further
Comment 2 Shannon Hughes 2009-07-15 12:18:34 EDT
satellite sync on vt channel and cache plus repod.xml was generated successfully.
Comment 3 wes hayutin 2009-07-15 12:44:07 EDT
I'd like to do some more testing on this..

testplan:
1. install a fresh satellite
2. sync channels, do not register any systems
3. verify repomd.xml files are created.

if someone else can run that scenario great... if not I'll do when I can
Comment 4 Shannon Hughes 2009-07-16 13:00:49 EDT
reassigning to wes since he wants to hit this one some more.
Comment 5 Devan Goodwin 2009-07-17 09:42:28 EDT
I'll take this, channels syncing on a systemless Satellite install now.
Comment 6 Devan Goodwin 2009-07-20 07:40:10 EDT
Satellite with no systems registered, synced i386 RHEL 5 and waited:

[root@fjs-0-09 ~]# ls /var/cache/rhn/repodata/
rhel-i386-server-5

Moving to verified.
Comment 7 Sayli Karmarkar 2009-09-01 18:24:45 EDT
After sat-sync (no registered systems):

[root@rlx-0-22 ~]# ls /var/cache/rhn/repodata/
rhel-i386-server-5

Moving to release_pending.
Comment 8 Brandon Perkins 2009-09-10 14:16:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.