Bug 507886 - dd_rescue inappropriately obsoletes ddrescue
dd_rescue inappropriately obsoletes ddrescue
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: dd_rescue (Show other bugs)
el5
All Linux
low Severity high
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 12:02 EDT by Mike Lococo
Modified: 2010-12-04 16:28 EST (History)
3 users (show)

See Also:
Fixed In Version: dd_rescue-1.23-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-27 18:37:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Lococo 2009-06-24 12:02:11 EDT
Description of problem:
dd_rescue innapropriately obsoletes ddrescue, please remove the "obsoletes: ddrescue" line from the spec file.

Version-Release number of selected component (if applicable):
1.14-7.fc9 (current version from the epel5 repository as of the filing of this bug)

How reproducible:
Always

Steps to Reproduce:
1. yum install ddrescue
  
Actual results:
... <snipped yum output>
Package ddrescue is obsoleted by dd_rescue, trying to install dd_rescue-1.12-6.el5.i386 instead
... <snipped yum output>

Expected results:
Install ddrescue, not dd_rescue.

Additional info:
* I believe that at one time in the past the dd_rescue software from http://www.garloff.de/kurt/linux/ddrescue/ was distributed inside a package named ddrescue.

* This was confusing because there is a different piece of software which provides similar functionality called ddrescue from http://www.gnu.org/software/ddrescue/ddrescue.html.  In order to resolve this confusion, dd_rescue was packaged under a package of the same name and was set to obsolete the ddrescue package (which at the time was just a duplicate)

* At some later point, ddrescue was packaged, but dd_rescue was not updated to remove the obsoletes line.

This naming kerfuffle appears to be documented somewhat in bug #434859.  At this point there appears to be no reason for the obsoletes, as the two pieces of software are entirely different alternatives to each other.
Comment 1 Mike Lococo 2010-07-09 12:29:11 EDT
This bug is still unresolved.  Is there any chance that the one-line fix that I suggested in my original report will be applied to the specfile?  ddrescue is by far the better of the two packages, providing a superset of the functionality in dd_rescue, but the standard install process is broken by this trivial dependency bug.
Comment 2 Susi Lehtola 2010-11-18 07:00:50 EST
ping?
Comment 3 Andreas Thienemann 2010-11-18 07:14:28 EST
Had a chat on IRC. Seems sensible. Will be done.
Comment 4 Fedora Update System 2010-11-18 20:28:58 EST
dd_rescue-1.23-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/dd_rescue-1.23-1.el5
Comment 5 Fedora Update System 2010-11-18 20:29:51 EST
dd_rescue-1.23-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/dd_rescue-1.23-1.fc14
Comment 6 Fedora Update System 2010-11-19 13:32:22 EST
dd_rescue-1.23-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dd_rescue'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/dd_rescue-1.23-1.el5
Comment 7 Fedora Update System 2010-11-27 18:37:32 EST
dd_rescue-1.23-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-12-04 16:28:17 EST
dd_rescue-1.23-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.