Bug 507908 - `eject cdrom` opens and immediately closes cdrom tray
`eject cdrom` opens and immediately closes cdrom tray
Status: CLOSED DUPLICATE of bug 453095
Product: Fedora
Classification: Fedora
Component: eject (Show other bugs)
11
All Linux
high Severity high
: ---
: ---
Assigned To: Zdenek Prikryl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 13:02 EDT by udo
Modified: 2010-02-21 10:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 04:43:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description udo 2009-06-24 13:02:36 EDT
Description of problem:
`eject cdrom` opens and immediately closes cdrom tray

Version-Release number of selected component (if applicable):


How reproducible:
eject-2.1.5-14.fc11.x86_64

Steps to Reproduce:
1. Do upgrade to F11
2. boot into F11
3. `eject cdrom`
  
Actual results:
Tray opens, tray closes immediately

Expected results:
Tray opens

Additional info:
$ eject -v cdrom
eject: device name is `cdrom'
eject: expanded name is `/dev/cdrom'
eject: `/dev/cdrom' is a link to `/dev/hda'
eject: `/dev/hda' is not mounted
eject: `/dev/hda' is not a mount point
eject: checking if device "/dev/hda" has a removable or hotpluggable flag
eject: `/dev/hda' is a multipartition device
eject: trying to eject `/dev/hda' using CD-ROM eject command
    (here is a pause of a few seconds!!!!)
eject: CD-ROM eject command succeeded

Because of this behaviour teh CD-ROM/writer is 99.8% unusable. This is a grave situation.
Comment 1 udo 2009-06-27 10:52:20 EDT
Same issue on an other F10 -> F11 PC with a Plextor DVD-writer instead of CD-rom.

How to debug?
Comment 2 udo 2009-06-27 10:53:21 EDT
And why is a cd-rom a multi-partition device?
Most of my discs have one session only.
Comment 3 udo 2009-06-28 13:15:21 EDT
After updating on the DVD-writer machine the eject command now works as expected on that machine. Is gvfs involved here?

On the CD-machine with the same gvfs etc the behaviour is unchanged: eject closes the tray immediately after opening.
Comment 4 Zdenek Prikryl 2009-06-29 04:43:24 EDT
The bug isn't in eject. It seems that this is a duplicate of the bug 453095.

*** This bug has been marked as a duplicate of bug 453095 ***
Comment 5 Douglas Mencken 2010-02-21 10:58:48 EST
I can confirm that.

How reproducible:
eject-2.1.5-15.fc12.ppc

Steps to Reproduce:
1. `eject /dev/hdc` or press "eject" button on keyboard or press eject button on device

Actual results:
Tray opens, tray closes immediately

Expected results:
Tray opens

Additional Info:

$ wodim --scanbus
scsibus1000:
	1000,0,0 100000) *
	1000,1,0 100001) *
	1000,2,0 100002) 'TSSTcorp' 'CDDVDW SH-S202J ' 'SB02' Removable CD-ROM
	1000,3,0 100003) *
	1000,4,0 100004) *
	1000,5,0 100005) *
	1000,6,0 100006) *
	1000,7,0 100007) *

Note You need to log in before you can comment on or make changes to this bug.