Bug 507937 - can't install or modify printers via root shell
can't install or modify printers via root shell
Status: CLOSED DUPLICATE of bug 447266
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 15:15 EDT by Art Werschulz
Modified: 2009-06-24 16:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 16:51:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Art Werschulz 2009-06-24 15:15:28 EDT
Description of problem:

Can't install or modify printers using a root shell.
You need to use 
  System -> Administration -> Printing
from the menu, which asks for the root password twice: once when fetching device list, again when applying the modification.
Note that this problem means that you can't do remote printer configuration.

Version-Release number of selected component (if applicable):
system-config-printer-1.1.7-4.fc11.i586

How reproducible:
See below.

Steps to Reproduce:
1. Launch a root shell (ssh -Y root@hostname)
2. Run the command 
   # system-config-printer
3. Try to add or modify a printer
  
Actual results:
Get a msg saying that you don't have sufficient privileges.

Expected results:
No such msg, and a fix.

Additional info:
When doing 
  System -> Administration -> Printing
from the menu, you're asked for the root password *twice*.
Comment 1 Tim Waugh 2009-06-24 16:51:02 EDT

*** This bug has been marked as a duplicate of bug 447266 ***

Note You need to log in before you can comment on or make changes to this bug.