Bug 50795 - ICE while compiling koffice's stream.cc
Summary: ICE while compiling koffice's stream.cc
Status: CLOSED DUPLICATE of bug 50244
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-03 12:41 UTC by Karsten Weiss
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-18 07:41:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The requested preprocessed source of stream.cc (43.90 KB, text/plain)
2001-08-17 18:48 UTC, Karsten Weiss
no flags Details

Description Karsten Weiss 2001-08-03 12:41:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010729

Description of problem:
gcc aborts compilation with an ICE at the file
koffice/filters/kspread/qpro/libqpro/src/stream.cc
of the current snapshot of KDE koffice.



How reproducible:
Always

Steps to Reproduce:
1. cvs co koffice
2. ./configure --prefix=/opt/kde-2.2 --enable-debug
3. make
	

Actual Results:  c++ -DHAVE_CONFIG_H -I. -I. -I../../../../.. -I. -I./..
-I/opt/kde-2.2/include -I/usr/lib/qt-2.3.1/include -I/usr/X11R6/include
-ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wbad-function-cast -Wcast-align
-Wundef -Wconversion -fno-builtin -Wnon-virtual-dtor -Wno-long-long -g -O2
-Wall -pedantic -W -Wpointer-arith -Wmissing-prototypes -Wwrite-strings
-fno-exceptions -fno-check-new -DQT_CLEAN_NAMESPACE -DQT_NO_COMPAT
-DQT_NO_ASCII_CAST -Wp,-MD,.deps/stream.pp -c stream.cc -fPIC -DPIC -o
.libs/stream.o
stream.cc: In method `QpIStream &QpIStream::operator>> (QP_INT64 &)':
stream.cc:192: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make: *** [stream.lo] Fehler 1



Additional info:

gcc (I tried both 2.96-85 and -95 from rawhide) shows the ICE with the
options "-Os", "-O1" and -"o2".
However, with "-O0" the compilation succeeds!

Comment 1 Jakub Jelinek 2001-08-17 18:36:25 UTC
Please provide preprocessed source (ie. add -save-temps option to c++
command line shown above and attach here stream.ii).
AFAIK we're building koffice without problems, so it must depend on exact
headers included in.

Comment 2 Karsten Weiss 2001-08-17 18:48:24 UTC
Created attachment 28333 [details]
The requested preprocessed source of stream.cc

Comment 3 Jakub Jelinek 2001-08-17 19:08:50 UTC
Can you try gcc-c++-2.96-96? This looks like #50244 (and in fact I cannot
reproduce it with 2.96-96).

Comment 4 Karsten Weiss 2001-08-18 07:41:27 UTC
Okay, the update to gcc-2.96-96 fixed the problem for me, too. Great job, Jakub!
(I don't close the bug by myself with this comment as I'm not sure if you
want to mark it as a duplicate or not.)

Comment 5 Jakub Jelinek 2001-08-20 12:46:22 UTC

*** This bug has been marked as a duplicate of 50244 ***


Note You need to log in before you can comment on or make changes to this bug.