Bug 50798 - ext3 partition not mountable under 7.1 as ext2
ext3 partition not mountable under 7.1 as ext2
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-03 09:50 EDT by Gene Czarcinski
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 11:22:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2001-08-03 09:50:04 EDT
Description of Problem:
Installed Roswell on /dev/hdb1.  Because of other problems, I rebooted and
came up on ly 7.1 system.  I then tried to mount /dev/hdb1 as ro ext2.

How Reproducible:
yes

Steps to Reproduce:
1.
2.
3.

Actual Results:

mount -t ext2 -o ro /dev/hdb1 /mnt/xx/
mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
       or too many mounted file systems

Expected Results:
parition mounted

Additional Information:
Comment 1 Stephen Tweedie 2001-08-03 10:22:36 EDT
Did you have any kernel log messages appear when you tried this?  What exactly
were the steps that you went through before rebooting into 7.1?

This behaviour is expected when an ext3 filesystem has not been cleanly
unmounted.  In that case, the information in the ext3 journal still needs to be
replayed before you can mount it safely as ext2.  Mounting as ext3 then
unmounting it will be sufficient.  Running e2fsck on the partition will also
work (I recommend using e2fsprogs-1.22 or later for that, though.)
Comment 2 Gene Czarcinski 2001-08-03 10:39:52 EDT
1. I had successfully shutdown the system on /dev/hdb1 and rebooted to 7.1 on
different partitions.

2. I got the following log message on the 7.1 system after trying a mount:

Aug  3 10:42:18 chaos kernel: EXT2-fs: ide0(3,65): couldn't mount because of
unsupported optional features (4).

3. I had successfully booted another Roswell install from yet another partition
and successfully mounted the hdb1 partition.
Comment 3 Stephen Tweedie 2001-08-03 10:52:13 EDT
Thanks, I'll try to reproduce this.  It's either a filesystem bug or a problem
with initscripts --- if the initscripts tell the kernel to mount the root
filesystem readonly before all the fs cleanup has been completed (in particular,
before all active-but-deleted files have been closed), the recovery bit will
remain set.  I'll investigate.

In any case, fsck on the filesystem should render it remountable as ext2.
Comment 4 Glen Foster 2001-08-06 18:28:02 EDT
This defect is considered SHOULD-FIX for Fairfax.
Comment 5 Stephen Tweedie 2001-08-24 10:41:41 EDT
Can you reproduce this?  In particular, can you capture a log of the ext3
shutdown which leads to this?

We've had some reports that old initscripts were not unmounting all filesystems
in the correct order.  Did you have any subdirectories under /usr mounted at the
same time?
Comment 6 Gene Czarcinski 2001-08-24 11:22:26 EDT
At this point I can't reproduce this.

I currently have just installed RC1 into this partition and everything looks OK.

I suggest this be closed as ??
Comment 7 Stephen Tweedie 2001-08-24 12:06:29 EDT
OK, done.

Note You need to log in before you can comment on or make changes to this bug.