This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 507999 - F11 Release Notes said boot.iso on CD,DVD, but it is not
F11 Release Notes said boot.iso on CD,DVD, but it is not
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
low Severity medium
: ---
: ---
Assigned To: John J. McDonough
Fedora Extras Quality Assurance
http://docs.fedoraproject.org/release...
:
: 513861 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-24 23:46 EDT by Tim Taiwanese Liim
Modified: 2013-01-10 00:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-24 16:46:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to replace troublesome text (2.26 KB, patch)
2009-07-26 16:18 EDT, Paul W. Frields
no flags Details | Diff

  None (edit)
Description Tim Taiwanese Liim 2009-06-24 23:46:32 EDT
Description of problem:
    The release notes [1][2] states
        2.4. Updated boot.iso
        The Fedora installation CDs and DVD provide you with an image
        file, boot.iso, ...

    But I could not find boot.iso on F11 CD/DVD.  Please update the
    release notes, or please point out where I can find boot.iso.
    Thanks.

    [1] http://docs.fedoraproject.org/release-notes/f11/en-US/sect-Release_Notes-Installation_Notes-Updated_boot.iso.html
    [2] file:///usr/share/doc/HTML/fedora-release-notes/en-US/fedora-release-notes-en-US.html#id2539766


Version-Release number of selected component (if applicable):
    fedora-release-notes-11.0.0-2.fc11.noarch


How reproducible:
    always

Steps to Reproduce:
    n/a
  
Actual results:
    n/a

Expected results:
    n/a

Additional info:
    n/a
Comment 1 Joseph Shraibman 2009-07-26 00:37:47 EDT
Did you ever find a solution for this?
Comment 2 Tim Taiwanese Liim 2009-07-26 12:59:52 EDT
Workaround:
Use the xxx-netinst.iso instead.
    Fedora-11-i386-netinst.iso
    Fedora-11-x86_64-netinst.iso
They are at the same location as xxx-DVD.iso.
Comment 3 Tim Taiwanese Liim 2009-07-26 13:12:20 EDT
According to Release Notes, I should use "Fedora Documentation"
instead of "Fedora" as Product.  So I created Bug 513861 for
the same issue, but with the proper Product.
Comment 4 Joseph Shraibman 2009-07-26 14:16:56 EDT
Ugh. 157 MB???!!! No wonder they didn't include it on the DVD image.  What happened to make it bloat so much?  This isn't going to fit on my 64 meg USB stick that I used to install Fedora 9
Comment 5 Joseph Shraibman 2009-07-26 15:15:22 EDT
OK so that image was totally what I did NOT want.  I didn't want to use anaconda to install over the internet, I wanted a minimal boot image so that I could install over NFS.  When I booted the image the grub based installer didn't have online help like the old LILO one did, so I had to reboot just to get documentation on how to specify the install method. Ugh again.
Comment 6 Paul W. Frields 2009-07-26 16:18:39 EDT
Created attachment 355210 [details]
Patch to replace troublesome text

I produced the attached changes but wasn't sure if this should go to master or some other branch.
Comment 7 Ruediger Landmann 2009-07-26 17:52:27 EDT
*** Bug 513861 has been marked as a duplicate of this bug. ***
Comment 8 Tim Taiwanese Liim 2009-07-26 17:55:31 EDT
Re: Comment #5, Comment #2
A revised workaround:
Use the xxx-netinst.iso instead.
    Fedora-11-i386-netinst.iso
    Fedora-11-x86_64-netinst.iso
They are at the same location as xxx-DVD.iso.  

When booting from said image,
1. Press <Tab> to access grub menu
2. add "askmethod" to kernel argument.
Comment 9 Tim Taiwanese Liim 2009-07-26 18:13:21 EDT
Re: Comment #6, Comment #7
Hi, Paul, Ruediger,
Thanks for fast action!

Paul,
In your revised text, you refer to "netinst.iso", but the actual files
are
    Fedora-11-i386-netinst.iso
    Fedora-11-x86_64-netinst.iso
Is there a way to make it clear to clueless users (like me) the files
are named xxx-netinst.iso?

Does xxx-netinst.iso works with BIOS?  I guess so, but it is not
crystal clear from your text.

Also, how about adding a few clue as how to install from NFS, as
Joseph pointed out, that we need?

> ... wasn't sure if this should go to master or some other branch.

Without knowing your procedure, I would vote for going to F11 updates,
just like other s/w updates.  Also I vote for updating [1], which is
visible to all.

Thanks!

[1] http://docs.fedoraproject.org/release-notes/f11/en-US/sect-Release_Notes-Installation_Notes-Updated_boot.iso.html
Comment 10 Tim Taiwanese Liim 2009-08-31 15:10:04 EDT
Paul, Ruediger,
Any news?  Thanks.
Comment 11 Tim Taiwanese Liim 2009-11-13 23:51:28 EST
Paul, Ruediger,
Will this be fixed in F12?
Thanks.
Comment 12 Tim Taiwanese Liim 2010-01-23 21:59:13 EST
Any news?  This remains an issue in F12.  Thanks.
Comment 13 Paul W. Frields 2010-01-24 16:46:33 EST
References to boot.iso and netinst.iso are not present in the most current versions of the Release Notes for Fedora 12 online:

http://docs.fedoraproject.org/release-notes/f12/en-US/html-single/

Instead, the documentation now refers to the Installation Guide and Installation Quick Start Guide, where complete information is available.
Comment 14 Tim Taiwanese Liim 2010-01-25 00:09:08 EST
Paul,
Thank you for your attention and response!  Yes I agree this bug
is resolved properly.

For the record:
- the related paragraph about boot.iso is now in Installation Guide
    http://docs.fedoraproject.org/install-guide/f12/en-US/html-single/

- boot.iso in F11,F12 exists in mirror sites
    Minimal CD boot media
            fedora/linux/releases/12/Fedora/arch/os/images/boot.iso

- but boot.iso does NOT exist in
    F11,F12 CD,DVD:/images/boot.iso
  where it used to be in F10 and before.

Note You need to log in before you can comment on or make changes to this bug.