Bug 508001 - Segmentation fault when reboot vm after hotplug and hot remove nic
Segmentation fault when reboot vm after hotplug and hot remove nic
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Glauber Costa
Lawrence Lim
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2009-06-25 00:52 EDT by Suqin Huang
Modified: 2014-03-25 20:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-30 17:58:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2009-06-25 00:52:45 EDT
Description of problem:
Segmentation fault when reboot vm after hotplug and hotunplug nic.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Hypervisor release 5.4-2.0.99 (7.1)
kvm-83-77.el5

How reproducible:
most of time

Steps to Reproduce:

1. command used:
#/usr/libexec/qemu-kvm -no-hpet -rtc-td-hack -smp 4 -m 2G -uuid `uuidgen` -net nic,model=e1000,macaddr=00:1a:4a:16:97:86,vlan=0 -net tap,vlan=0,script=/etc/qemu-ifup -drive file=RHEL-5.4-64.qcow2,if=ide -boot c -vnc :10 -monitor stdio
2. #modprobe acpiphp
3. (qemu) pci_add pci_addr=auto nic vlan=0,model=virtio
4. (qemu)pci_del pci_addr=4
5. reboot vm

segmentation fault:

#0  0x00000000000004a0 in ?? ()
#1  0x00000000004160fb in virtio_reset (opaque=<value optimized out>)
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/hw/virtio.c:500
#2  0x00000000004075f6 in qemu_system_reset ()
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/vl.c:3759
#3  0x00000000005166e2 in qemu_kvm_system_reset ()
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/qemu-kvm.c:375
#4  0x0000000000516855 in kvm_main_loop ()
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/qemu-kvm.c:605
#5  0x000000000040e415 in main (argc=21, argv=0x7fff62b12a08, 
    envp=<value optimized out>)
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/vl.c:3967


#0  0x0000000000470374 in qemu_set_irq (irq=0x430610, level=0)
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/hw/irq.c:38
#1  0x00000000004075f6 in qemu_system_reset ()
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/vl.c:3759
#2  0x00000000005166e2 in qemu_kvm_system_reset ()
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/qemu-kvm.c:375
#3  0x0000000000516855 in kvm_main_loop ()
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/qemu-kvm.c:605
#4  0x000000000040e415 in main (argc=21, argv=0x7fffd4b4c418, 
    envp=<value optimized out>)
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/vl.c:3967


boot model=virtio/rtl8139, hotplug/hotunplug e1000/rtl8139/virtio also have this issue.

  
Actual results:


Expected results:


Additional info:

guest info:
rhel5.4-64
Comment 1 Mark McLoughlin 2009-10-29 09:59:55 EDT
Looks like we need qemu_unregister_reset() backported

Note You need to log in before you can comment on or make changes to this bug.