Bug 50802 - system and keyboard locks up on apmd start
system and keyboard locks up on apmd start
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-03 10:01 EDT by carpnic
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 12:31:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description carpnic 2001-08-03 10:01:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-GB; m18) Gecko/20010131
Netscape6/6.01

Description of problem:
The laptop is a sharp pc-ax10 ultralight
When linux tries to start the apmd, the system locks up and i can't do
anything but switch it off. I disabled the apmd at start up and tried to
start it manually but the result is the same. It also locks up when i touch
any of the battery monitoring setups that are available.

In the messages log file it has the line: apm:BIOS Version 1.2 Flags 0x03 (
Driver version 1.14)
I assume from this that apm support is in the kernel

How reproducible:
Always

Steps to Reproduce:
1.Let linux start apmd at boot time	
2.or start apmd at command line
3.or on interactive start up say no to apmd, once started let linuxconf
start it on exit
	

Actual Results:  System hangs/crashes. No keyboard or mouse

Expected Results:  All apmd features

Additional info:
Comment 1 Bernhard Rosenkraenzer 2001-08-04 15:48:07 EDT
This is definitely a bug in your BIOS.
Please attach more info about the BIOS so we can add it to the blacklist.
Comment 2 carpnic 2001-08-05 01:25:47 EDT
When i had rh7.0 istalled this problem was not present. The only problem i had 
when 7.0 was installed was the battery capacity was incorrectly reported and 
when on batteries the capacity would remain at 52 percent and not change. This 
is probably a bios fault

What info do you need about the bios and how can i get it.
Comment 3 carpnic 2001-08-15 10:25:25 EDT
Hi

I think my problem with the apmd is a configuration problem. I would like to
know if the daemon looks at any config file as it starts as there might be
something in them that is causing the problem.

The reason i ask is that i clicked on the XF86config program in X11R6/bin while
in an x environment which messed up x so it wouldn't start. But when i restarted
the machine in runlevel 3 the apm daemon started ok. I had to reload rh to fix
the x problem which also brought back the apm problem.

Any help would be appreciated

Thanks
Carl
Comment 4 carpnic 2001-08-21 10:27:36 EDT
Hi

I was looking at the init.d/ampd file to see if there was anything in it that
could cause a problem. The first line that has;
#  Don't bother if /proc/apm doesn't exist, kernel has not support for APM.
[ -e /proc/apm ] || exit 0

I checked to see if this /proc/apm was there, it was. When i went to view the
contents of this file, my machine crashed and froze up completely.  This is
where my system is failing when the apm daemon is starting. Is ther any way to
fix it.

Thanks Carl
Comment 5 Arjan van de Ven 2001-08-21 10:31:22 EDT
You can add "noapm" to the kernel commandline. If that works, could you
please download the program at

http://people.redhat.com/arjanv/dmidecode.c

and (as root) do
gcc dmidecode.c -o dmidecode
./dmidecode | mail -s "apm crashes" hardwarebugs-list@redhat.com

the last commands sends an email with system information so please run the
./dmidecode program standalone and look at the output and make sure you're
comfortable to send this info, before sending the actual mail.
Comment 6 carpnic 2001-08-22 09:39:13 EDT
When you say kernel command line i asume you mean at the lilo prompt as: linux
noapm
Does this just stop the apm daemon from starting? 

I have disabled the apmd from starting to get my laptop running, but if i try to
use cat on the /proc/apm to view the contents or even just view, it locks my
machine.

The laptop has a win modem and i have no driver for it to run the program. If it
run stand alone does it produce a file that i could send if you would like me to
still run this program.

Carl
Comment 7 Arjan van de Ven 2001-08-22 09:47:08 EDT
apologies; noapm should have been "apm=off", and yes the lilo prompt.
Comment 8 carpnic 2001-08-23 10:54:13 EDT
I started linux with the apm=off option and this has removed the proc/apm file.
I have run the dmidecode file on the machine and sent a text file attachment,
since i have no modem for the laptop, to hardwarebugs-list@redhat.com. Does this
put this machine on the blacklist. 

Would a kernel upgrade fix the problem since this problem did not occur when i
had rh7.0 installed before i loaded rh7.1.

Carl
Comment 9 Arjan van de Ven 2001-08-23 11:05:55 EDT
"Does this put this machine on the blacklist. "
I will add this machine to the list of machines to automatically do "apm=off"
for.

I don't know why a 2.2 kernel worked before. APM got changed a great deal in
order to support suspend and resume better; maybe the new code uses something
the bios doesn't provide properly.

Note You need to log in before you can comment on or make changes to this bug.