Bug 508021 - --nofiledigest is ignored when installing
--nofiledigest is ignored when installing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 03:42 EDT by Àlex Magaz Graça
Modified: 2009-08-04 20:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.7.1-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-04 20:41:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Àlex Magaz Graça 2009-06-25 03:42:39 EDT
Description of problem:

rpm does digest checking even when --nofiledigest is specified.

Version-Release number of selected component (if applicable):

rpm-4.7.0-1.fc11.i586

How reproducible:

Always.

Steps to Reproduce:
1. Download http://www.mozart-oz.org/download/mozart-ftp/store/1.4.0-2008-07-03-GENERIC-i386/mozart-1.4.0.20080704-16189.i386.rpm

2. run:
  # rpm -ivh --nofiledigest mozart-1.4.0.20080704-16189.i386.rpm

  
Actual results:

error: unpacking of archive failed on file /usr/lib/mozart/platform/linux-i486/lib/libgcc_s.so.1;4a431d2f: cpio: Digest mismatch

Expected results:

The package gets installed.

Additional info:

It worked on Fedora 9 but started to fail with Fedora 10.
Comment 1 Panu Matilainen 2009-06-27 04:28:22 EDT
Right, it's caused by popt option conflict (there are at least two other similar conflicts) from rearranging things between 4.4.x and 4.6.x. Will fix.
Comment 2 Panu Matilainen 2009-07-14 06:59:30 EDT
Fixed upstream.
Comment 3 Fedora Update System 2009-07-24 01:16:56 EDT
rpm-4.7.1-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rpm-4.7.1-1.fc11
Comment 4 Fedora Update System 2009-07-24 15:40:00 EDT
rpm-4.7.1-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7986
Comment 5 Fedora Update System 2009-08-04 20:40:37 EDT
rpm-4.7.1-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.