Bug 50803 - Add version number to the %{DISTRIBUTION} tag
Summary: Add version number to the %{DISTRIBUTION} tag
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-03 14:02 UTC by Vidar Langseid
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-03 14:02:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vidar Langseid 2001-08-03 14:02:18 UTC
Description of Problem:
This is more like a feature request for your building environment, not for
the rpm-build package itself.

Rpms shipped with RedHat 7.1 has this DISTRIBUTION tag value:
# rpm -q --queryformat "%{DISTRIBUTION}\n" bash
Red Hat Linux

I think that it would be great if the rh version number also was added to
this tag (optioanlly add a DISTRIBUTIONVERSION tag) like this
# rpm -q --queryformat "%{DISTRIBUTION}\n" bash
Red Hat Linux 7.1

rh is not binary compatible between (major) versions. You already have the
depency checking for this but I think it would be a nice feature. It  would
be nice to use when querying rpms which is not yet installed

I hope this will be considered before the next rh release.

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Jeff Johnson 2001-08-03 14:09:50 UTC
Adding some way of detecting binary incompatibilities is needed,
but Distribution: is not the answer because:
	1) packages built from one Red Hat distribution are
	frequently shipped with another distribution.
	2) there's a whole lot of variance in the values taken
	on by the Distribution tag, even for Red Hat packages.
	Basically, you can't trust what's in the Distribution: tag.
	3) Distribution is pure mechanism, there's no clear semantics
	for when/if/how "binary compatibile" should be reflected in
	a changed Distribution: version.


Note You need to log in before you can comment on or make changes to this bug.