Bug 50806 - Screen shifts up on kde and gnome wont start
Summary: Screen shifts up on kde and gnome wont start
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-applets (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-03 14:32 UTC by carpnic
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-23 13:41:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config-4 File (1.93 KB, text/plain)
2001-08-05 05:06 UTC, carpnic
no flags Details
XF86Config File (14.27 KB, text/plain)
2001-08-05 05:10 UTC, carpnic
no flags Details

Description carpnic 2001-08-03 14:32:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-GB; m18) Gecko/20010131
Netscape6/6.01

Description of problem:
I have a sharp pc ax10 ultralight notebook running 7.1 seawolf(dual boot).
It has an ATI rage mobility using the pci bus with 4mb memory (it maybe
shared memory, not sure). It is set for 1024x768 16bit
When the login screen displays, the full screen is used. When logging into
kde (and gnome when i had 7.0 installed) the screen appears to shift up
leaving approx 5mm(3/16")blank at the bottom. Also gnome refuses to start
and locks the system. These two faults may be related to the same problem.

How reproducible:
Always

Steps to Reproduce:
1.Log in to kde or gnome
2.
3.
	

Actual Results:  5mm(3/16") high blank protion at the bottom of the screen

Expected Results:  Full screen used

Additional info:

Comment 1 carpnic 2001-08-05 05:06:39 UTC
Created attachment 26273 [details]
XF86Config-4 File

Comment 2 carpnic 2001-08-05 05:10:53 UTC
Created attachment 26274 [details]
XF86Config File

Comment 3 carpnic 2001-08-05 05:14:13 UTC
I have attached the XF86Config and XF86Config-4 files for you. 
I also found the update rpm for the XFree86-mach64 and went to install it and 
found that it had not been installed on my system. I have installed it but do 
not know how to get linux to use it as i am still new to linux. This may fix my 
problem

Comment 4 carpnic 2001-08-15 14:15:05 UTC
Hi

Xconfigurator detects the graphics as Rage Mobility P/M but says none to the x
server and will not use the mach64 server. I ran Xconfigurator with the --expert
and --server options selecting the mach64 server. This has fixed the problem of
the screen shifting up.

However gnome still refuses to start fully. It displays the desktop icons and
the gnome hints screen then stops at th loading of the panel. The whole system
is frozen.

I think i might know what is causing it but do not know how to fix it with out
getting gnome started first. I have a problem with the apmd and anything that
relates to battery monitoring and i think the battery monitor capplet/applet is
on the panel. If there is a config file i can edit to remove it from starting it
might allow gnome to start. RH61 has a file called Applet_Config that details
the applets but i can not find this file in RH71. Is there an equivalent.

Thanks
Carl

Comment 5 Mike A. Harris 2001-08-18 03:16:26 UTC
This is indeed a problem with apm and the battery applet, and is not
an XFree86 bug.

Comment 6 David Mason 2001-08-20 13:51:37 UTC
alex - battery applet or pass it on to apm owner?

Comment 7 Alexander Larsson 2001-08-20 15:53:11 UTC
I can't help you with your apm problems, but if you edit the
$HOME/.gnome/panel.d/default/Applet_Config file and remove the battery applet
entry you should be able to start gnome.

I added an entry and it looked like this:
[Applet_13]
id=Extern
goad_id=battery_applet
position=51
panel=0
right_stick=false


Just remove it.


Comment 8 carpnic 2001-08-21 14:36:47 UTC
Hi

I do not have this file or directory "panel.d/default/Applet_Config" in the
.gnome directory. 

Carl

Comment 9 Alexander Larsson 2001-08-21 16:32:58 UTC
Very strange?
Do you have any Applet_Config at all?
what does 
find ~/ -name Applet_Config
output?

As a simple fix you could always rename the battery applet so the panel won't
find it.




Comment 10 carpnic 2001-08-22 13:23:04 UTC
I tried the find ~/ -name Applet_Config returned nothing . I have also tried
locate and whereis on the whole drive without finding it.

I renamed the battery_applet file in /usr/bin but gnome still will not start and
still locks the system up completely.  

Carl

Comment 11 carpnic 2001-08-23 13:41:12 UTC
I obtained a copy of ximian gnome 1.4 and installed it on my machine. The new
version of gnome starts ok and works ok. There is also the Applet_Config file in
panel.d/default. 

If this directory and file does not exist can this cause gnome to fail in
startup. It seems that when i installed rh71 the installation was not complete
for some unkown reason.

Thankyou for all your assistance.

Carl

Comment 12 Alexander Larsson 2001-08-23 14:56:11 UTC
Well. That particular file should get created on initial login. 

Anyway, cool that you got this working. I'm closing this bug then.



Note You need to log in before you can comment on or make changes to this bug.