Bug 508060 - Option XkbLayout doesn't work
Option XkbLayout doesn't work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 08:37 EDT by Miroslav Lichvar
Modified: 2018-04-11 09:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 04:39:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg output (2.62 KB, text/plain)
2009-06-25 08:37 EDT, Miroslav Lichvar
no flags Details
Xorg config (1.36 KB, text/plain)
2009-06-25 08:38 EDT, Miroslav Lichvar
no flags Details
Xorg log (34.53 KB, text/plain)
2009-06-25 08:39 EDT, Miroslav Lichvar
no flags Details

  None (edit)
Description Miroslav Lichvar 2009-06-25 08:37:51 EDT
Created attachment 349386 [details]
Xorg output

Description of problem:

Not sure this is an xorg-x11-drv-keyboard problem, please reassign if not.

When in xorg.conf is specified:
Option      "XkbLayout" "us,cz_qwerty"

The layouts are not loaded and keyboard doesn't work correctly. Calling setxkbmap -layout 'us,cz' later works.

In Xorg output (not in the log) is:

The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            Can't find file "cz_qwerty" for symbols include
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server


The same xorg.conf worked in F10.

Version-Release number of selected component (if applicable):
xorg-x11-drv-keyboard-1.3.2-3.fc11.x86_64
Comment 1 Miroslav Lichvar 2009-06-25 08:38:50 EDT
Created attachment 349387 [details]
Xorg config
Comment 2 Miroslav Lichvar 2009-06-25 08:39:59 EDT
Created attachment 349388 [details]
Xorg log
Comment 3 Miroslav Lichvar 2009-06-25 08:52:38 EDT
Hm, it works when "us,cz" is specified in xorg.conf, only "us,cz_qwerty" doesn't.

Is this a xkeyboard-config problem?
Comment 4 Matěj Cepl 2009-06-27 10:20:17 EDT
Peter, is it a good idea to use .fdi file in /etc/hal even for language configuration as described on https://fedoraproject.org/wiki/Input_device_configuration ???
Comment 5 Peter Hutterer 2009-06-28 18:08:47 EDT
Miroslav:
try "us,cz(qwerty)" instead.
Any particular reason why you are forcing the keyboard driver btw? (AutoAddDevices off)



Matej: no, generally we don't recommend it. the fdi files are set up from /etc/sysconfig/keyboard and then gnome takes over anyways and applies its own setup (KDE doesn't touch the keyboard layout by default).
Comment 6 Miroslav Lichvar 2009-06-30 04:39:59 EDT
"us,cz(qwerty)" works, but only with setxkbmap.

I found another syntax, when XkbVariant ",qwerty" is specified in xorg.conf, it works.

I'm using kbd driver because evdev didn't work qemu, maybe it's fixed now.

Thanks.
Comment 7 Peter Hutterer 2009-06-30 18:33:48 EDT
(In reply to comment #6)
> I found another syntax, when XkbVariant ",qwerty" is specified in xorg.conf, it
> works.

FTR, this adds up to the same thing as the variants are paired up with the layout. so a layout of "a,b" with a variant of "C, D" is equivalent to setxkbmap -layout "a(C),b(D)". Empty variants (like in your case) thus require a simple comma.

Note You need to log in before you can comment on or make changes to this bug.