Bug 50807 - KDE desktop settings wizard language choices inconsistent
KDE desktop settings wizard language choices inconsistent
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-03 10:44 EDT by Megan Bock
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-03 10:44:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Megan Bock 2001-08-03 10:44:27 EDT
Description of Problem:
The new Desktop Settings wizard in KDE 2.2 beta 1 does not generate the 
same language options each time you install the OS. Within an 
installation, every account that starts KDE will see the same options, but 
after reinstalling, different options are shown.

How Reproducible:
Consistent within installation. Varies from installation to installation.

Steps to Reproduce:
1. Start KDE from a user account that has never run KDE.
2. Drop the "Please choose your language" list.
3. Select Other.

Actual Results:
Different results from three different installations. All were installed 
from the same set of Roswell CDs. First installation was text mode, with 
all packages. Second was GUI installation with all groups. Third 
installation was GUI with all groups, with all KDE packages explicitly 
selected. All installations specified US English everywhere possible.

First & third installations: Suggested language was Czech. List also 
showed as options Spansih (es) and Default (C). The "Other" languages 
option popped out a menu that included about 2 dozen languages. UK English 
was an option, but no other English (ie, US English) was listed.

Second installation: This time the only language that appeared in the list 
was "Default (c)". The "Other" list also contained only Default (C).


Expected Results:
- Expected to see same language list each time. 
- Expected "Other" list to have other choices. 
- Expected that suggested language would be based on installation settings.
- Expected that if English is defined as UK, another English option would 
be present. 

Additional Information:
Comment 1 Bernhard Rosenkraenzer 2001-08-04 18:06:22 EDT
Fixed in 2.2-0.cvs20010801.1 and higher. The problem was that the locale for
English is "C", and just looking if a string contained that brought up "Cs"
(Czech) and "Ca" (Catalan) as possible results.

Note You need to log in before you can comment on or make changes to this bug.