Bug 508073 - Hard crash during boot at "find_video+0x67" (kernel-2.6.31-0.28.rc1.fc12.x86_64)
Hard crash during boot at "find_video+0x67" (kernel-2.6.31-0.28.rc1.fc12.x86_64)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 09:50 EDT by Tom London
Modified: 2013-01-10 02:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 13:02:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Camera shot of boot crash (209.18 KB, image/jpeg)
2009-06-25 09:50 EDT, Tom London
no flags Details
Second camera shot of frozen boot (208.71 KB, image/jpeg)
2009-06-26 09:53 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2009-06-25 09:50:01 EDT
Created attachment 349401 [details]
Camera shot of boot crash

Description of problem:
kernel-2.6.31-0.28.rc1.fc12.x86_64 is DOA on my system:
Thinkpad X200, Intel graphics.

It crashes very quickly during the boot with a stack trace, the top item being:

find_video+0x67/0xa7
acpi_nm_walk_namespace+0xc9

The top of the trace is off the top of my screen.

I attach a camera shot of the screen.

Booting kernel-2.6.31-0.25.rc0.git22.fc12.x86_64 boots just fine.

Version-Release number of selected component (if applicable):
kernel-2.6.31-0.28.rc1.fc12.x86_64

How reproducible:
Every boot!

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-06-25 10:01:11 EDT
lspci output:

[root@tlondon ~]# lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
[root@tlondon ~]#
Comment 2 Tom London 2009-06-26 09:53:19 EDT
Created attachment 349552 [details]
Second camera shot of frozen boot

Boot fails with kernel-2.6.31-0.29.rc1.fc12.x86_64 too.

So, both -0.28 and -0.29 fail quite early in boot process at find_video().

Fails both with and without plymouth.
Comment 3 Tom London 2009-06-26 10:03:18 EDT
Also fails with "nomodeset": I get a completely black screen.....
Comment 4 Tom London 2009-06-26 22:20:49 EDT
kernel-2.6.31-0.32.rc1.git2.fc12.x86_64 fails with (apparently) same trace .....
Comment 5 Tom London 2009-06-27 01:11:28 EDT
Same crash with kernel-2.6.31-0.33.rc1.git2.fc12.x86_64 ...
Comment 6 Matthew Garrett 2009-06-29 15:13:18 EDT
Upstream bug due to some PCI updates. Should be fixed soon.
Comment 7 Tom London 2009-06-30 12:47:22 EDT
Seem to be able to boot OK with kernel-2.6.31-0.35.rc1.git5.fc12.x86_64....


This fixed?
Comment 8 Matthew Garrett 2009-06-30 13:02:46 EDT
Looks like.

Note You need to log in before you can comment on or make changes to this bug.