Bug 508145 - QMF agent seg faulting with large method output
QMF agent seg faulting with large method output
Status: CLOSED DUPLICATE of bug 510747
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
1.1.1
All Linux
low Severity medium
: 1.3
: ---
Assigned To: Ted Ross
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 15:42 EDT by Matthew Farrellee
Modified: 2011-08-12 12:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-08 10:50:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2009-06-25 15:42:56 EDT
Description of problem:

I have a method that returns a FT of FTs of FTs. When the method result is to the tune of maybe 10+MB it will consistently seg fault. This crash is also taking out gdb, so the traces I've received are somewhat suspect but only implicate the C++ agent. I can clearly see execution succeed to the point where ManagementMethod returns.

Version-Release number of selected component (if applicable):

$ rpm -q qpidc qmf     
qpidc-0.5.752600-5.fc10.i386
qmf-0.5.752600-5.fc10.i386


How reproducible:

100%


Steps to Reproduce:
1.invoke QMF method that constructs a rather large response structure
Comment 1 Ted Ross 2009-09-08 10:50:19 EDT

*** This bug has been marked as a duplicate of bug 510747 ***

Note You need to log in before you can comment on or make changes to this bug.