Bug 50817 - virtual pop accounts can't pop after upgrading to imap200c
virtual pop accounts can't pop after upgrading to imap200c
Status: CLOSED DUPLICATE of bug 49604
Product: Red Hat Linux
Classification: Retired
Component: imap (Show other bugs)
6.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-03 12:09 EDT by Jacob Killian
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-03 14:51:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacob Killian 2001-08-03 12:09:19 EDT
Description of Problem:

After upgrading to imap2000c, virtual pop accounts can't login and get 
mail.  They can receive mail (new mail shows up in 
/var/spool/vmail/username).  Primary domain pop users can get mail 
through ipop3d.

Client gets the following message: "-ERR Bad login"

/var/log/messages reports: "Aug  3 10:35:57 mail1 ipop3d[19027]: Login 
failure user=info@vdomain.com host=[10.10.10.13]"  There is not the 
corresponding PAM message, which indicates a bad username/password.

/var/log/maillog reports nothing.

/var/log/secure reports the ipop3d connection	


How Reproducible:

Every time

Steps to Reproduce:

1. Install RH 6.2
2. Add a virtual pop account
3. Upgrade to imap2000c
4. Attempt to pop mail for the virtual pop account.

Actual Results:

See description.

Expected Results:

Login and retrieve mail.

Additional Information:

# uname -a
Linux mail1.primarydomain.com 2.2.14-5.0smp #1 SMP Tue Mar 7 21:01:40 EST 
2000 i686 unknown

# rpm -qif /usr/sbin/ipop3d
Name        : imap                         Relocations: (not relocateable)
Version     : 2000c                             Vendor: Red Hat, Inc.
Release     : 1.6.0                         Build Date: Sun 08 Jul 2001 
04:39:51 AM CDT
Install date: Mon 30 Jul 2001 03:51:28 PM CDT      Build Host: 
porky.devel.redhat.com
Group       : System Environment/Daemons    Source RPM: 
imap-2000c-1.6.0.src.rpm
Size        : 2244234                          License: University of 
Washington's Free-Fork License
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.washington.edu/imap/
Summary     : Server daemons for IMAP and POP network mail protocols.
Comment 1 Mike A. Harris 2001-08-03 14:38:29 EDT

*** This bug has been marked as a duplicate of 49604 ***
Comment 2 Jacob Killian 2001-08-03 14:51:43 EDT
Um, I don't think this is the same problem...regular users can still get their
mail through ipop3d, it's only the virtual pop accounts which are having
problems.  Also, the imap and pop entries in /etc/pam.d/ are there, contrary to
what was reported in bug id #49604.

If you still think it's the same problem, when can I expect to see the errata
update?
Comment 3 Mike A. Harris 2001-08-03 14:58:37 EDT
This bug is caused by the missing pamauth stuff.  The files were
omitted from the errata accidentally.  You can use the older files
as they are the same.

Errata will be out when it is ready.

*** This bug has been marked as a duplicate of 49604 ***
Comment 4 Need Real Name 2001-11-17 01:03:26 EST
I have the 1.6.1 release installed, and the virtual pops still dont work. It 
appears not to check for the name of the user under the virtual server.
There are two entrys in /etc/pam.d/pop
#%PAM-1.0
auth       required     /lib/security/pam_pwdb.so shadow nullok
account    required     /lib/security/pam_pwdb.so
[root@test pam.d]# 

all latest patches installed. (current rpms)
[root@test /root]# rpm -q imap-2000c
imap-2000c-1.6.1
[root@test /root]# rpm -q imap-devel-2000c
imap-devel-2000c-1.6.1

Any suggestions? Virtual directorys exist
in /vhome/virtualdomain/home/username

I dont see where the password files for the virtual users is though?
Thought they were supposed to be in
/vhome/virtualdomain/etc ?

After telneting to my same system using two different names it would appear 
that the pop3 demon does not reconize the name? see below
bash# telnet test.longhofer.com pop-3
Trying 63.67.80.200...
Connected to test.longhofer.com (63.67.80.200).
Escape character is '^]'.
+OK POP3 test.longhofer.com v2000.70rh server ready
bye
-ERR Unknown AUTHORIZATION state command

^]

telnet> bye
?Invalid command
telnet> quit
Connection closed.
bash# telnet sinistah.com pop-3
Trying 63.67.80.200...
Connected to sinistah.com (63.67.80.200).
Escape character is '^]'.
+OK POP3 test.longhofer.com v2000.70rh server ready

I have created the sinistah.com virtual mail listing
and created pop only users in the sinistah.com relm.

It appears that the pop3 demon can not differ. After reading around the web a 
bit, is it required to install vpop3d on RH 6.2 to make this work?

Any suggestions?
Rod Longhofer

Note You need to log in before you can comment on or make changes to this bug.