Bug 508204 - libgphoto2 hangs on FC11 and shuts down camera
libgphoto2 hangs on FC11 and shuts down camera
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libgphoto2 (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 23:46 EDT by Arnav
Modified: 2013-07-02 19:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:18:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
libgphoto2 hangs on FC11: debug Log (24.48 KB, application/x-bzip)
2009-06-25 23:46 EDT, Arnav
no flags Details

  None (edit)
Description Arnav 2009-06-25 23:46:40 EDT
Created attachment 349505 [details]
libgphoto2 hangs on FC11: debug Log 

Description of problem:
I upgraded from FC9 to a stock FC11.  In FC9, gphoto worked flawlessly without an issue.  gphoto detects the camera correctly:
# gphoto2 --auto-detect
Model                          Port                                            
----------------------------------------------------------
Canon PowerShot S2 IS (PTP mode) usb:            
Canon PowerShot S2 IS (PTP mode) usb:001,009

I am also able to configure the camera such as:
# gphoto2 --set-config capture=on --set-config zoom=60 --set-config iso=0 --set-config owner=Arnav

However, ghoto hangs when I try to actually capture an image (e.g. "gphoto2 --capture-image" or "gphoto2 --capture-image-and-download") and I need to kill it eventually.  Even worse, executing the above shuts the camera down.

Please see attached log.

Version-Release number of selected component (if applicable):
gphoto2         2.4.5          gcc, popt(m), exif, no cdk, no aa, jpeg, readline
libgphoto2      2.4.5          gcc, ltdl, EXIF
libgphoto2_port 0.8.0          gcc, ltdl, USB, serial baudboy locking

How reproducible:  always


Steps to Reproduce:
1.  install stock FC11 gphoto2.
2.  run:  "gphoto2 --set-config capture=on --set-config zoom=60 --set-config iso=0 --set-config owner=yourname"
3.  run: "gphoto2 --capture-image-and-download --force-overwrite --filename=webcam.jpg"
  
Actual results:  gphoto hangs, camera shuts down

Expected results:  A picture is taken remotely and downloaded to local machine
Comment 1 Marcus Meissner 2009-07-04 19:06:18 EDT
it aborted communication in the middle of the protocol.

did it switch off the camera?
is there anything in dmesg?

might be overly aggressive USB powersaving in FC11 for instance or some new
usb interactions :/
Comment 2 Arnav 2009-07-04 20:08:57 EDT
Hi Marcus,

Yes, it switched off the camera.  I am away from this particular machine for the next few hours, so I will post dmesg output later.  I have a hunch it is libgphoto2 and not FC11, but it is ultimately for you experts to confirm (and apologies in advance if I am completely off base).
At face value, the symptoms are the same as I have been tracking with you here:
http://sourceforge.net/tracker/?func=detail&aid=2794538&group_id=8874&atid=108874
I hope you can find the time to compare the logs logged here against FC11 vs. those logged against FC9 in the SourceForge tracker.  In both cases gphoto2 hangs and the camera shuts down.

If indeed it the turns out the underlying issue is the same, it seems to suggest the problem is with libgphoto2 and started somewhere between 2.4.0 and 2.4.5 (which is not a very helpful observation i know..)
If it turns out the underlying issue is different, then I am happy it is logged separately against FC11.  

Here is a recap of what I have observed so far:
- Verified/confirmed to be working great with libgphoto2 2.4.0 (FC9)
- Unstable with libgphoto2 2.4.3 (FC11)
- Not working with libgphoto2 2.4.5 and libgphoto2 2.4.6 (FC11 and FC9) 

Due to libtool changes in FC11 (https://fedoraproject.org/wiki/Libtool2) I was not able to install older versions of libgphoto2 on FC11, but I have tested 2.4.5 and 2.4.6 and the issue is the same in both.  I found libgphoto2 2.4.3 to be very temperamental in FC11 (but it could be due to the changes suggested by the article above to get things working with the new version of libtool).  Please let me know if there are certain other combinations you would like me to try..  Many thanks in advance for the help.
Comment 3 Arnav 2009-07-05 13:29:59 EDT
Here is the output from dmesg.  I have no idea what it means (but it seems like a gvfs failure?)

fuse init (API version 7.11)
usb 1-1.1: new high speed USB device using ehci_hcd and address 7
usb 1-1.1: New USB device found, idVendor=04a9, idProduct=30f0
usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-1.1: Product: Canon Digital Camera
usb 1-1.1: Manufacturer: Canon Inc.
usb 1-1.1: configuration #1 chosen from 1 choice
usb 3-1.3: usbfs: USBDEVFS_CONTROL failed cmd gvfs-gphoto2-vo rqt 128 rq 6 len 1000 ret -110
usb 3-1.3: usbfs: USBDEVFS_CONTROL failed cmd gvfsd-gphoto2 rqt 128 rq 6 len 1000 ret -110
usb 3-1.3: usbfs: USBDEVFS_CONTROL failed cmd gphoto2 rqt 128 rq 6 len 1000 ret -110
usb 3-1.3: usbfs: USBDEVFS_CONTROL failed cmd gphoto2 rqt 128 rq 6 len 1000 ret -110
usb 1-1.1: USB disconnect, address 7

Does that help to zero in on the problem?
Comment 4 Marcus Meissner 2009-07-06 11:06:08 EDT
no, looks harmless.

that gvfs-gphoto is accesing the camera might be an issue, but I doubt it. This would be seen earlier.

you can try:
gvfs-mount -s gphoto2:
to umount the gphoto2 slave from gvfs.
Comment 5 Arnav 2009-07-07 00:42:52 EDT
no luck.

I tried "gvfs-mount -s gphoto2" after plugging the camera and the results are the same.  dmesg contains exactly the same messages. 
I am not convinced gvfs-mount does what it suppose to do though.
First, "gvfs-mount -l" doesn't list the camera as mounted (even tough it should).
Then,"gvfs-mount -s gphoto2" doesn't seem to actually unmount the Camera.  To unmount it I need to go to nautilus, right-click the camera, and select "unmount camera."  Only that actually unmounts the camera.

I tested after un-mounting in nautilus but the results were the same.    

Also, I did the following test as well: after connecting the camera, I killed the gvfs-gphoto2-volume-monitor but the results were the same.   

What do you make of this?
Comment 6 Marcus Meissner 2009-07-07 05:45:34 EDT
that gvfs is unrelated to this issue. :/

I am a bit at loss now. :/
Comment 7 Bug Zapper 2010-04-27 11:15:55 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2010-06-28 09:18:07 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.