Bug 508217 - S-c-tools cleanup: "New Root Password" input box shows password in tooltip
S-c-tools cleanup: "New Root Password" input box shows password in tooltip
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-rootpassword (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 493609
  Show dependency treegraph
 
Reported: 2009-06-26 04:27 EDT by Jaroslav Reznik
Modified: 2009-09-14 07:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-14 07:22:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch for this bug (731 bytes, patch)
2009-08-24 03:48 EDT, Radek Novacek
no flags Details | Diff

  None (edit)
Description Jaroslav Reznik 2009-06-26 04:27:13 EDT
Description of problem: "New Root Password" input box shows password in tooltip.

system-config-rootpassword-1.99.4-4.fc11.noarch

Steps to Reproduce:
1. run s-c-rootpassword
2. type password by it shows strength of password
3. now check "New Root Password" input box tooltip

Actual results:
New password shown in tooltip.

Expected results:
No passwords shown in tooltip.

Additional info:
This bug report is part of "System Configuration Tools Cleanup Project". Don't
hesitate to ask project maintainers for any kind of help.
Comment 1 Radek Novacek 2009-08-24 03:48:09 EDT
Created attachment 358421 [details]
Proposed patch for this bug

This bug was caused by changes in the cracklib library interface. In previous versions the method FascistCheck returned the error string but now it throws a ValueError exception. This patch fixes this issue.
Comment 2 Lubomir Rintel 2009-09-14 07:22:23 EDT
Commited. Thanks for the patch. (feel free to apply for svn/cvs access)

Note You need to log in before you can comment on or make changes to this bug.