Bug 508253 - Cannot seek in flac files
Cannot seek in flac files
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 06:44 EDT by Michael Monreal
Modified: 2009-10-19 05:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.10.15-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-16 17:29:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Monreal 2009-06-26 06:44:42 EDT
I can seek in mp3 and oga file just fine with Totem, but if I try the same with flac files, I get an error:

---
Es ist ein Fehler aufgetreten
Konnte den Datenstrom nicht decodieren.
---

which roughly translates into

---
An error has occurred
Could not decode the data stream
---

The flac file was produces with sound-juicer using the default flac profile. It plays fine in totem as long as I don't seek.
Also, seeking the same file(s) works fine in other gstreamer based apps (tested with banshee).
Comment 1 Steve 2009-06-27 04:55:41 EDT
Same here: An error occurred; Could not decode stream.

Only with flac files.

totem-2.26.2-1.fc11.i586
flac-1.2.1-5.fc11.i586
Comment 2 Michael Monreal 2009-06-29 06:04:19 EDT
I Have just noticed that I get the same error when playing flac on my other system (Ubuntu, with totem 2.27.x from git) so this seems to be an upstream bug.
Comment 3 Steve 2009-07-23 15:05:13 EDT
The bug persists in totem-2.26.3-1.fc11.i586.
Comment 4 Fedora Update System 2009-07-24 15:37:38 EDT
gstreamer-plugins-good-0.10.15-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gstreamer-plugins-good'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7934
Comment 5 Michael Monreal 2009-07-24 16:06:50 EDT
I do no longer see the warning/error pop up, and the seeking _seems_ to work, kind of (time moves on correctly when moving the slider). However, after the seek (when no longer moving the slider), playback does not resume. Pressing play/pause again does not change this.
Comment 6 Steve 2009-07-25 03:27:07 EDT
Just the error message is gone, seeking does work but not play.
Comment 7 Fedora Update System 2009-07-27 17:36:20 EDT
gstreamer-plugins-good-0.10.15-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Michael Monreal 2009-07-27 17:47:13 EDT
As Steve has also confirmed that this is not fixed, can someone please reopen the bug?
Comment 9 Bastien Nocera 2009-07-27 18:02:20 EDT
A note on the upstream bug would have been more useful.
Comment 10 Michael Monreal 2009-07-27 18:12:10 EDT
For reference, where exactly can we find this upstream bug?
Comment 11 Bastien Nocera 2009-07-27 18:26:22 EDT
http://bugzilla.gnome.org/show_bug.cgi?id=578612
Comment 12 Bastien Nocera 2009-07-29 11:00:58 EDT
To whoever can reproduce the problem, please file a separate upstream bug, with the data required in:
http://bugzilla.gnome.org/show_bug.cgi?id=578612#c8
Comment 13 Michael Monreal 2009-07-30 05:46:22 EDT
I can still reproduce the bug on my Fedora 11 system (which is unchanged from what Fedora provides). However, on my other system I recently upgraded all gstreamer modules to git master and there it works now. So I guess the fix here depends on some unreleased fix in gstreamer or gst-plugins-basic?
Comment 14 Michael Monreal 2009-08-17 17:24:52 EDT
I just found out that seeking flac works fine in totem on rawhide (with very latest -good). So I installed the F12 totem packages on F11 and flac seeking magically works now. So, either the F12 totem package has a special patch or the problem is fixed upstream in 2.27.x
Comment 15 Bastien Nocera 2009-10-16 17:29:53 EDT
F11 has the same version of gstreamer packages as F12 available, so I'll assume this is fixed.
Comment 16 Steve 2009-10-17 03:17:12 EDT
This in not fixed in F11, please reopen!

Note You need to log in before you can comment on or make changes to this bug.