Bug 508270 - Can not cancel a remote connection
Can not cancel a remote connection
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 07:37 EDT by Qunfang Zhang
Modified: 2009-12-14 16:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-13 21:52:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qunfang Zhang 2009-06-26 07:37:53 EDT
Description of problem:
When double-click a remote connetion to make it runing, there's a password dialogue poping up. But it can't be canceld.

Version-Release number of selected component (if applicable):
virt-manager-0.6.1-3.el5

How reproducible:
100%

Steps to Reproduce:
1.Double-click a  remote connection that is disconnected.
2.A window pops up requesting the password of remote machine.
3.Click “Cancel” button.
  
Actual results:
It's unavailable.The window still exists and after I click Cancel button several times, there will be a error poping up,says:
Unable to open a connection to the libvirt management deamon.
Libvirt.libvirtError cannot recv data:Connection reset by peer None.

Expected results:
The password dialogue closes.

Additional info:
Details:
Unable to open connetion to hypervisor URI'qumu+ssh://root@dhcp-66-70-37/system':
libvirt.libvirtError cannot recv data: Connection reset by peer None.
Comment 2 Cole Robinson 2009-06-26 09:57:11 EDT
This is not a regression. This popup dialog comes straight from ssh, so offhand I don't know what we can do to change this behavior.
Comment 4 Cole Robinson 2009-12-13 21:52:35 EST
Since this dialog comes straight from SSH, and it in fact _can_ be cancelled (you just have to click 'cancel' 3 times), I don't think this behavior needs to changed. So closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.