Bug 50830 - dos2unix is missing mac2unix softlink and does not convert text files properly
dos2unix is missing mac2unix softlink and does not convert text files properly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dos2unix (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Aaron Brown
:
Depends On:
Blocks: FC3Target FC3BugWeekTracker FC3BugWeekQA
  Show dependency treegraph
 
Reported: 2001-08-03 15:20 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-25 18:57:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-03 15:20:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)

Description of problem:
The version of dos2unix that ships with RedHat-7.1 does not include the
mac2unix softlink. It also does not convert text files properly. It has a
tendency to mangle the "CR-LF"s and make the text file from a Mac or
Windows PC not much more useable after the conversion.

How reproducible:
Always

Steps to Reproduce:
1. get a mac or windows plain text file.
2. dos2unix -o winfilename.txt linuxfilename.txt
3. less linuxfilename.txt
	

Actual Results:  The above commands will still not translate the file
properly.

Expected Results:  Properly translated files that I can work with in Linux.

Additional info:

This is a minor bug in the overall picture of things BUT it is very
importatnt to me because I have lots of Windows and Mac clients and they
have no way of coping with properly formatted text files.
Comment 1 Tom Tromey 2001-12-14 12:33:34 EST
I note we're also missing a `unix2dos' link.
Both mac2unix and unix2dos are referenced in the dos2unix man page,
so this is potentially confusing.
Comment 2 Colin Charles 2004-09-13 22:28:34 EDT
We now have: (even in FC2) from unix2dos-3.1-18
/usr/bin/unix2dos

and from dos2unix-3.1-18
/usr/bin/dos2unix
/usr/bin/mac2unix

So, the next question is, does it all work as planned (no OS9 or
Windows boxes around, to test)
Comment 3 Rik van Riel 2004-09-24 16:17:09 EDT
Updating status, this is something that only needs testing, no
development.
Comment 4 Ulrich Drepper 2004-09-24 21:41:02 EDT
I've tested the versions from comment #2 with some self-generated
DOS/Mac files and all seems to be peechy.  I think the bug should be
closed as CURRENTRELEASE.
Comment 5 Mike A. Harris 2004-09-25 18:57:24 EDT
Thanks for the testing update Uli.  Setting status to
"CURRENTRELEASE".

Note You need to log in before you can comment on or make changes to this bug.