Bug 508301 - Plug-in crashed: "help-browser" (/usr/lib64/gimp/2.0/plug-ins/help-browser)
Plug-in crashed: "help-browser" (/usr/lib64/gimp/2.0/plug-ins/help-browser)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 09:24 EDT by Ralf Corsepius
Modified: 2009-07-22 18:01 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.6.6-6.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 18:01:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2009-06-26 09:24:24 EDT
Description of problem:

Clicking onto "Help" in Gimp's main menu fails.

Instead a two message boxes pop up, one telling

"Plug-in crashed: "help-browser"
(/usr/lib64/gimp/2.0/plug-ins/help-browser)

The dying plug-in may have messed up GIMP's internal state. You may want to save your images and restart GIMP to be on the safe side.
[OK]"

another one:

"Could not start the GIMP help browser plug-in.
[Cancel]     [Use Web Browser]"


When lauching gimp from a terminal, at the same time an error message shows:
GLib-ERROR **: The thread system is not yet initialized.
aborting...



Version-Release number of selected component (if applicable):
# rpm -qa 'gimp*'
gimp-help-2.4.2-4.fc11.noarch
gimp-help-browser-2.6.6-3.fc11.x86_64
gimp-2.6.6-3.fc11.x86_64
gimp-libs-2.6.6-3.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. on a console run "gimp"
2. In gimp's main menu click on Help->Help
3.
  
Actual results:
c.f. above

Expected results:
Function.

Additional info:
Comment 1 Ralf Corsepius 2009-06-26 10:22:16 EDT
FYI: I am able to reproduce this bug on further machines, comprising i586s.
Comment 2 Fedora Update System 2009-06-28 05:47:07 EDT
gimp-2.6.6-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gimp-2.6.6-5.fc11
Comment 3 Nils Philippsen 2009-06-28 05:49:13 EDT
Hi Ralf, please test gimp-2.6.6-5 once it's available, it contains a backported fix needed for the new webkit version which is in F-11.
Comment 4 Ralf Corsepius 2009-06-28 07:00:58 EDT
(In reply to comment #3)
> Hi Ralf, please test gimp-2.6.6-5 once it's available, it contains a backported
> fix needed for the new webkit version which is in F-11.

With 
# rpm -qa 'gimp*'
gimp-help-2.4.2-4.fc11.noarch
gimp-help-browser-2.6.6-5.fc11.x86_64
gimp-2.6.6-5.fc11.x86_64
gimp-libs-2.6.6-5.fc11.x86_64

The Help->Help crash seems to be fixed.

However, now, the help-browser crashes on some of its submenus, 
e.g. when double-clicking
"1. GIMP User Manual Authors and Contributors"
inside of the help-browser.
Comment 5 Nils Philippsen 2009-06-29 04:42:50 EDT
(In reply to comment #4)
> However, now, the help-browser crashes on some of its submenus, 
> e.g. when double-clicking
> "1. GIMP User Manual Authors and Contributors"
> inside of the help-browser.  

I've checked it and seen the same behaviour with webkitgtk-1.1.4 installed. Please update the webkitgtk package to version 1.1.8 which is available from updates-testing and fixed this problem for me.
Comment 6 Nils Philippsen 2009-06-29 05:40:54 EDT
Well, it didn't really, it just crashes a few clicks more down the road.
Comment 7 Ralf Corsepius 2009-06-29 05:45:43 EDT
(In reply to comment #5)
> (In reply to comment #4)
> Please update the webkitgtk package to version 1.1.8 which is available from
> updates-testing and fixed this problem for me.  

With
# rpm -qa 'gimp*' 'webkit*'
gimp-help-2.4.2-4.fc11.noarch
gimp-help-browser-2.6.6-5.fc11.x86_64
webkitgtk-1.1.8-1.fc11.x86_64
gimp-2.6.6-5.fc11.x86_64
gimp-libs-2.6.6-5.fc11.x86_64

I am observing this, when clicking on "1. GIMP User Manual Authors and Contributors":
* (help-browser:29062): CRITICAL **: const gchar* webkit_web_history_item_get_title(WebKitWebHistoryItem*): assertion `WEBKIT_IS_WEB_HISTORY_ITEM(webHistoryItem)' failed

Later, when digging deeper though the menus, similar error messages show up, until the help-browser finally dumps core:

...
** (help-browser:29062): CRITICAL **: const gchar* webkit_web_history_item_get_title(WebKitWebHistoryItem*): assertion `WEBKIT_IS_WEB_HISTORY_ITEM(webHistoryItem)' failed

** (help-browser:29062): CRITICAL **: const gchar* webkit_web_history_item_get_title(WebKitWebHistoryItem*): assertion `WEBKIT_IS_WEB_HISTORY_ITEM(webHistoryItem)' failed
/usr/lib64/gimp/2.0/plug-ins/help-browser: fatal error: Segmentation fault


Smells like an entirely broken plugin system, to me ;)


(In reply to comment #6)
> Well, it didn't really, it just crashes a few clicks more down the road.  
Yep.
Comment 8 Nils Philippsen 2009-06-29 07:41:38 EDT
(In reply to comment #7)
> Smells like an entirely broken plugin system, to me ;)

Not really, it's just the help browser plugin that's broken (with the new versions of webkitgtk which we have in F-11 and later). I've found a patch in the upstream git repo which should fix it for good, though. Expect gimp-2.6.6-6 soon in an updates-testing near you ;-).
Comment 9 Fedora Update System 2009-06-30 17:26:02 EDT
gimp-2.6.6-6.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gimp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7081
Comment 10 Ralf Corsepius 2009-07-01 01:52:34 EDT
(In reply to comment #9)
> gimp-2.6.6-6.fc11 has been pushed to the Fedora 11 testing repository.
> http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7081  

This one seems to fix my issues. Thanks!
Comment 11 Fedora Update System 2009-07-22 18:01:07 EDT
gimp-2.6.6-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.