Bug 508326 - Force use of /sys/bus/usb for all USB host devices
Force use of /sys/bus/usb for all USB host devices
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-06-26 11:48 EDT by Daniel Berrange
Modified: 2009-07-03 04:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-03 04:33:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2009-06-26 11:48:52 EDT
Description of problem:
The QEMU USB host device support has code for accessing devices via three different location

 /dev/bus/usb
 /proc/bus/usb
 /sys/bus/usb

The first 2 are legacy locations, and /sys/bus/usb is the preferred location for modern kernels.

QEMU currently probes for each of these in turn, and tries the preferred sysfs option last. This is a problem for sVirt since the first two will generate AVC alerts as the SELinux labelling will never allow access to them.

/sys/bus/usb will be shortly gaining support for fine grained SELinux labelling allowing devices to be labelled for individual guests.

Since Fedora only needs to support modern kernels, QEMU should not bother trying to use /dev/bus/usb or /proc/bus/usb, and instead go straight to /sys/bus/usb. This will avoid the needless AVCS.

Thus this BZ is to request commenting outof the code for using /dev and /proc for USB devices.

Version-Release number of selected component (if applicable):
qemu-0.10.5-3.fc11.i586

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mark McLoughlin 2009-07-03 04:33:46 EDT
Fix sent upstream and built in rawhide

* Fri Jul  3 2009 Mark McLoughlin <markmc@redhat.com> - 2:0.10.50-8.kvm87
- Prefer sysfs over usbfs for usb passthrough (#508326)

Note You need to log in before you can comment on or make changes to this bug.