Bug 508334 - checking for available subscriptions with a guest that has no host causes an ISE
checking for available subscriptions with a guest that has no host causes an ISE
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Registration (Show other bugs)
rhn511
All Linux
low Severity medium
: ---
: ---
Assigned To: Grant Gainey
Red Hat Network Quality Assurance
us=111264 US153
: Reopened
Depends On:
Blocks: 510541 rhn-sprint32
  Show dependency treegraph
 
Reported: 2009-06-26 12:19 EDT by James Bowes
Modified: 2013-01-10 05:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-16 15:24:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Bowes 2009-06-26 12:19:15 EDT
If you have no free physical entitlements, and no free FVEs, and you are trying to register a virtual guest that has no host known to RHN, then during the remaining subscriptions call, RHN will ISE, instead of returning 0.
Comment 1 James Bowes 2009-07-17 09:25:15 EDT
FWIW, this has to be a kvm guest, it seems.
Comment 2 Denise Hughes 2009-07-17 16:18:13 EDT
Verified in webdev.

Steps for Testing:
1. ssh root@rlx-0-20.rhndev.redhat.com
2. ssh -p 1111 localhost
3. Run rhn_register
4. tail the logs and verify no errors
5. Verify the system is registered in RHN
Comment 3 Denise Hughes 2009-07-30 15:46:41 EDT
Cannot be verified in webqa.  No access to the machine for testing.  Setting status to verified.
Comment 4 James Bowes 2009-09-15 07:42:56 EDT
The change I made for this bug is causing tracebacks in production. Should be an easy fix; the SQL is just plain wrong (see commit 530479)
Comment 6 Grant Gainey 2009-10-20 14:10:20 EDT
TEST PLAN:
=========

* THERE EXISTS an account with NO entitlements remaining
* THERE EXISTS a 5.4 KVM Host system, "HOST"
* THERE EXISTS on that system a KVM guest, "GUEST"
* HOST is NOT REGISTERED to RHN

1) Log in to GUEST
2) Run rhn_register

EXPECTED:
========
Registration fails cleanly, due to no remaining entitlements.  No errors in the logs on the rhnxml box or on GUEST.

3) Give the account entitlements
4) Login to GUEST
5) Run rhn_register

EXPECTED:
========
GUEST registers with hosted

6) Log in to HOST
7) Run rhn_register
8) Give HOST Virtualization entitlement

EXPECTED:
========
HOST shows GUEST as one of its guest systems in WEBUI
Comment 8 Denise Hughes 2009-10-22 12:20:21 EDT
Verified on webdev.

Testopia ID:
https://testopia.devel.redhat.com/bugzilla/tr_show_case.cgi?case_id=13085
Comment 9 Stephen Herr 2009-12-09 13:03:58 EST
verified on webqa

Note that I can't reproduce the failure on any environment now, so I'll just trust that the test plan in this bz is accurate.
Comment 10 Denise Hughes 2009-12-16 15:24:00 EST
Fix in production.

Note You need to log in before you can comment on or make changes to this bug.