Bug 50839 - RFE: The JavaScript version sucks a lot of memory
RFE: The JavaScript version sucks a lot of memory
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.8
i386 Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-03 16:03 EDT by Cristian Gafton
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 12:33:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cristian Gafton 2001-08-03 16:03:39 EDT
Description of Problem:

I'm not sure that there is much that can be done, but the javascript
version makes the netscape process go all the way up to 270MB of RAM.
Seems a bit excessive...

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 David Lawrence 2001-08-06 12:23:13 EDT
Which screen are you referring to? The bug entry forms or the query page? The
query page needs total reworking because each distro release introduces even
components and cause even more javascript to be created for each query page.
Comment 2 Cristian Gafton 2001-08-06 12:28:17 EDT
The query page
Comment 3 David Lawrence 2001-08-06 12:33:41 EDT
Changing to an enhancement request. This will take some time to fix unless we
just disallow javascript from that page altogether. I only use the javascript
version when I want to create custom queries to save for later anyway. Most
people won't use it on a regular basis.
Comment 4 David Lawrence 2001-09-11 00:16:32 EDT
There has beens some improvements made to the Javascript query interface. The
size of the page is less than half of what it was and seems to be more
responsive now. Please try it and reopen this bug if you have any problems.

Note You need to log in before you can comment on or make changes to this bug.