Bug 508426 - gnome-power-manager - many problems
gnome-power-manager - many problems
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-27 00:14 EDT by Mustafa Mehmed
Modified: 2010-06-28 09:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:19:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mustafa Mehmed 2009-06-27 00:14:11 EDT
Description of problem:

Observations:-
1. Boot on AC power (HP Laptop model DV6746tx 2 years old)
2. Pull AC cord
3. No change seen
  expect to see
    a. popup notification
    b. reduce backlight brightness (set via gnome-power-manager)
    c. some history and statistics in Power Stats - Device history - see no data
4. still thinks AC adapter online
5. can suspend/hibernate manually
6. Reconnect AC adapter
    see a popup - "Your battery is fully charged"  (not correct)
7. Pull AC again
   a. screen dims as expected
   b. AC adapter correctly identified as not online
   c. still no data in stats/history
8. reconnect AC adapter
   a. popup says "Battery is Discharging" - back to front
   b. screen back to full brightness (correct)
9. Pull AC again
   a. screen dims (correct)
   b. no popup notifications
10. Reconnect AC
   a. popup says "Battery discharging"
   b. screen back to full brightness (correct)

Version-Release number of selected component (if applicable):

dbus-1.2.12-1.fc11.i586
libnotify-0.4.5-2.fc11.i586
gnome-power-manager-2.26.2-1.fc11.i586
kernel 2.6.29.5-191.fc11.i686.PAE
hal-0.5.12-26.20090226git.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
see above

Expected results:
see above

Additional info:
I have resubmitted this bug. The original was "Bug 564810 – Discharge time profile has no statistics" on http://bugzilla.gnome.org/show_bug.cgi?id=564810 submitted by me. That bug is yet to be triaged.

I hope to get some more joy here. This has been present since F10 came out and is still present in F11. (F9 power-management worked perfectly)

If anymore info is needed please let me know. Thanks.
Comment 1 Richard Hughes 2009-06-28 04:08:58 EDT
What does "devkit-power --monitor" display when you plug and unplug? It's unlikely to be a g-p-m problem.
Comment 2 Mustafa Mehmed 2009-06-28 07:40:59 EDT
$ devkit-power --monitor
Monitoring activity from the power daemon. Press Ctrl+C to cancel.

AC unplugged 

device changed:     /org/freedesktop/DeviceKit/Power/devices/line_power_ACAD
device changed:     /org/freedesktop/DeviceKit/Power/devices/battery_BAT0

AC plugged

Popup "You battery is now fully charged" (not correct)

device changed:     /org/freedesktop/DeviceKit/Power/devices/battery_BAT0
device changed:     /org/freedesktop/DeviceKit/Power/devices/battery_BAT0
device changed:     /org/freedesktop/DeviceKit/Power/devices/line_power_ACAD
device changed:     /org/freedesktop/DeviceKit/Power/devices/battery_BAT0



then  (still plugged in) 

device changed:     /org/freedesktop/DeviceKit/Power/devices/battery_BAT0
device changed:     /org/freedesktop/DeviceKit/Power/devices/battery_BAT0
device changed:     /org/freedesktop/DeviceKit/Power/devices/battery_BAT0
device changed:     /org/freedesktop/DeviceKit/Power/devices/battery_BAT0
device changed:     /org/freedesktop/DeviceKit/Power/devices/battery_BAT0

Statistics TAB in "Power Statistics - Device Profile" now has data

History TAB has a single dot at 0.0W at about 6 minutes for Rate
Charge has data
Time to full has no data
Time to Empty has no data

Hope this helps
Comment 3 Mustafa Mehmed 2009-07-04 19:59:51 EDT
Hughsie,

I need to know who to send this bug report off to, to get it resolved. Thanks.
Comment 4 Richard Hughes 2009-08-20 08:02:17 EDT
Does installing the latest gnome-power-manager and DeviceKit packages in updates-testing (and then rebooting...) fix the problem?
Comment 5 Mustafa Mehmed 2009-08-20 20:33:30 EDT
# yum --disablerepo=* --enablerepo=updates-testing upgrade gnome-power-manager DeviceKit-power

# reboot

1. boot on AC power
2. pull AC --> popup says "you battery is fully charged"
3. ~ 30 seconds later --> popup says "you are now on battery power" or words to that effect
4. Check Power Stats --> shows still on AC power
5. Power Stats - Device History shows -->
   rate - nothing
   charge - shows graph (looks ok)
   time to full/empty - nothing

Upgrade to testing does not appear to have made any difference.

# rpm -q gnome-power-manager DeviceKit-power
gnome-power-manager-2.26.4-1.fc11.i586
DeviceKit-power-010-0.3.20090810git.fc11.i586
Comment 6 Mustafa Mehmed 2009-08-20 20:35:52 EDT
More info. Pulling AC and replugging AC gives me _same_ popup, "your battery is now fully charged" which is patently incorrect.

# devkit-power --monitor
Monitoring activity from the power daemon. Press Ctrl+C to cancel.
device changed:     /org/freedesktop/DeviceKit/Power/devices/line_power_ACAD
device changed:     /org/freedesktop/DeviceKit/Power/devices/battery_BAT0
device changed:     /org/freedesktop/DeviceKit/Power/devices/battery_BAT0
device changed:     /org/freedesktop/DeviceKit/Power/devices/battery_BAT0
device changed:     /org/freedesktop/DeviceKit/Power/devices/battery_BAT0
Comment 7 Bug Zapper 2010-04-27 11:17:12 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2010-06-28 09:19:19 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.