Bug 508427 - default compiler path is set incorrectly
default compiler path is set incorrectly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: codeblocks (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-27 01:05 EDT by John Poelstra
Modified: 2009-07-01 16:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-01 16:54:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Poelstra 2009-06-27 01:05:59 EDT
Description of problem:
default compiler path is set incorrectly and defaults to /usr/lib64

Version-Release number of selected component (if applicable):
codeblocks-8.02-7.fc11.x86_64

How reproducible:
100%

To fix the problem manually:
Under "Settings" select "Compiler and debugger..."

Then scroll the list of the tabs by clicking the arrow to the right of Compiler settings, Linker settings, Search directories until you get to Toolchain executables.

Change the path to /usr/bin

Now "Hello World" builds and runs from the IDE

Couldn't /usr/bin be set correctly to start with?
Comment 1 Dan Horák 2009-06-27 05:04:14 EDT
Hm, it looks like #469096. I will take a look what could be different in F-11.
Comment 2 Dan Horák 2009-07-01 05:06:29 EDT
John, do you see this behaviour on fresh install of F-11 or on an update from earlier release? If it's an update, can you try
  mv .codeblock .codeblocks.orig
in your home dir and try starting C::B again? Because on my fresh F-11 install with ccache installed, the path (/usr) is detected correctly.
Comment 3 John Poelstra 2009-07-01 16:54:42 EDT
My apologies.  I just realized what happened.

I originally an rpm from the code::blocks site, but then later found that it was in the Fedora repos.  I bet what happened is that my .codeblocks dir was created with the first rpm and not from the Fedora repo.

Note You need to log in before you can comment on or make changes to this bug.