Bug 50844 - An alias for "which" for (t)csh is only annoying.
An alias for "which" for (t)csh is only annoying.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: which (Show other bugs)
7.3
All Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-03 16:21 EDT by Göran Uddeborg
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-03 16:21:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2001-08-03 16:21:26 EDT
The package "which" includes a file which-2.csh in profile.d which sets up
an alias for which for those shells.  I find this annoying, prefering the
version of which built-in to the shells, since it is more precise and is
what I'm used to.  I can of course easily fix this for myself with an
"unalias" in my .cshrc.  But I would guess most tcsh users would have the
same opinion, so I suggest the file is removed from the package.

(The which-2.sh file is of course quite ok.  This is about the (t)csh
version only.)
Comment 1 Ngo Than 2001-08-04 10:02:04 EDT
It's fixed in 2.12-3. You will find it in next rawhide

Note You need to log in before you can comment on or make changes to this bug.