Bug 508448 - system-config-printer crash if root use it for managing printers
system-config-printer crash if root use it for managing printers
Status: CLOSED DUPLICATE of bug 447266
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-27 06:30 EDT by Sergei LITVINENKO
Modified: 2009-06-29 07:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 07:22:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergei LITVINENKO 2009-06-27 06:30:32 EDT
Description of problem:
If root try to manage printers, application crash on final phase or show "permission deny" message.

Version-Release number of selected component (if applicable):
system-config-printer-1.1.7-4.fc11.i586

How reproducible:
100%

Steps to Reproduce:
1. open terminal (I use konsole under KDE)
2. su -
3. system-config-printer
4. add new printer
5. confirm changing
  
Actual results:

Caught fatal exception.  Traceback:
File "/usr/share/system-config-printer/system-config-printer.py", line 6501, in on_btnNPApply_clicked
    device=uri, info=info, location=location)
File "/usr/share/system-config-printer/authconn.py", line 183, in <lambda>
    return lambda *args, **kwds: self._authloop (fname, fn, *args, **kwds)
File "/usr/share/system-config-printer/authconn.py", line 198, in _authloop
    result = fn.__call__ (*args, **kwds)
File "/usr/share/system-config-printer/cupspk.py", line 486, in addPrinter
    *args, **kwds)
File "/usr/share/system-config-printer/cupspk.py", line 230, in _call_with_pk_and_fallback
    debugprint ('PolicyKit call to %s did not work: %s' %
NameError: global name 'debugprint' is not defined
Exiting

Expected results:
All changes are commited. New printer is available for use.

Additional info:

user can manage printers by system-config-printer.
Comment 1 Tim Waugh 2009-06-29 07:22:27 EDT
There are two problems here:

1. The traceback, which occurs when authentication fails. This is fixed in the system-config-printer package available in updates-testing and is tracked by bug #496722.

2. PolicyKit denies operations when requested by root. This is a PolicyKit issue and is tracked by bug #447266.

*** This bug has been marked as a duplicate of bug 447266 ***

Note You need to log in before you can comment on or make changes to this bug.