Bug 50845 - configure reports error during check for glob
configure reports error during check for glob
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-03 16:50 EDT by Nathan Owen
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-03 16:55:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes logic wrt glob in configure.in (976 bytes, patch)
2001-08-03 16:54 EDT, Nathan Owen
no flags Details | Diff

  None (edit)
Description Nathan Owen 2001-08-03 16:50:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en] (X11; U; SunOS 5.6 sun4u)

Description of problem:
When building from CVS configure complains about arguments to test during
the check for the GNU extentions to glob.

How reproducible:
Always

Steps to Reproduce:
1. ./autogen.sh
	

Actual Results:  ...
checking for ftok... yes
checking for glob... yes
checking for GNU extensions to glob... ./configure: test: =: unary operator
expected
checking for python 1.5.2... yes
checking for doxygen... /usr/bin/doxygen
...

Expected Results:  ...
checking for ftok... yes
checking for glob... yes
checking for GNU extensions to glob... yes
checking for python 1.5.2... yes
checking for doxygen... /usr/bin/doxygen
...

Additional info:

I am attaching a patch that quotes the relevant tests and reverses the
logic in the cache check (I think that was the reason that $rpm_cv_glob_ext
was slipping through without assigned a value)
Comment 1 Nathan Owen 2001-08-03 16:54:59 EDT
Created attachment 26151 [details]
Fixes logic wrt glob in configure.in
Comment 2 Jeff Johnson 2001-08-04 10:13:26 EDT
FIxed in next checkin, should be in rpm-4.0.3-0.86.
Thanks for the patch.

Note You need to log in before you can comment on or make changes to this bug.