Bug 508461 - solar theme in fedora11 has no splash screen
solar theme in fedora11 has no splash screen
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: solar-kde-theme (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-27 08:13 EDT by Mohammed Arafa
Modified: 2009-08-03 15:22 EDT (History)
8 users (show)

See Also:
Fixed In Version: 0.1.17-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-03 15:22:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Arafa 2009-06-27 08:13:31 EDT
Description of problem:
i m not sure if this is the correct package but i like the solar theme. so when i selected the solar them splash screen from the system settings and logged in again, i did not see anything except the background. no splash screen.

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. install all kde packages with the name solar
2. kde/system settings/appearance/splash screen
3. select solarcomet / apply
4. you can also try with "test theme" which will fail
  
Actual results:
no splash screen


Expected results:
see the splash screen that was used for kde in fedora10


Additional info:
solar-backgrounds-0.92.0-2.fc11.noarch
plymouth-theme-solar-0.7.0-0.2009.05.15.1.fc11.x86_64
solar-kde-theme-0.1.17-4.fc11.noarch
solar-backgrounds-common-0.92.0-2.fc11.noarch
Comment 1 Kevin Kofler 2009-06-27 13:48:07 EDT
The KSplash theme for F9 was in fedora-logos because it contains the Fedora logo, it got kicked out in F10 because fedora-logos usually doesn't carry old themes for the obvious space reasons (it's present on all our spins).
Comment 2 Kevin Kofler 2009-06-27 13:49:24 EDT
Oh, and it doesn't work properly with KDE 4.2 anyway: it is not centered properly, it's stuck in the upper left corner of the screen. :-(
Comment 3 Kevin Kofler 2009-06-27 13:51:02 EDT
Oh wait... Silly me, I was thinking of the Waves theme!

For Solar, there's just one image which used to be in fedora-logos in F10 and probably got kicked out in F11. We could add the "KDE 4" image from the F10 generic-logos.
Comment 4 Mohammed Arafa 2009-06-27 15:35:45 EDT
yes please!
Comment 5 Jaroslav Reznik 2009-06-29 06:12:38 EDT
Ops, Solar theme had to be banned from F11 but now once it's already released I'll fix it... Sorry.
Comment 6 Kevin Kofler 2009-06-29 07:04:26 EDT
I wonder if we can just symlink the image from the Leonidas directory which is provided by the current fedora-logos and generic-logos.

And I don't see why we should drop old themes as long as they still work. Of course it's probably not worth the effort to port old KDE 3 KDM themes to KDE 4 (so we just dropped those in F9) nor to fix the F9 Waves splash screen's centering problems with KDE 4.2 now (and that one was in the F9 fedora-logos, so it's no longer available anyway), but those themes which still work should still be provided.
Comment 7 Jaroslav Reznik 2009-07-13 10:43:00 EDT
Ok, if you think it's worth to support old themes, I'll do it. There's one issue - Fedora/KDE logo in fedora/generic-logos. Well we should install it to the common pixmaps directory to avoid linking it from other theme (as Leonidas is the case here).
Comment 8 Fedora Update System 2009-07-13 11:44:20 EDT
solar-kde-theme-0.1.17-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/solar-kde-theme-0.1.17-5.fc11
Comment 9 Fedora Update System 2009-07-19 06:06:14 EDT
solar-kde-theme-0.1.17-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update solar-kde-theme'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7697
Comment 10 Mohammed Arafa 2009-08-01 13:31:26 EDT
works like a charm

thanks
Comment 11 Fedora Update System 2009-08-03 15:22:34 EDT
solar-kde-theme-0.1.17-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.