Bug 508465 - anaconda hangs when entering passphrase
anaconda hangs when entering passphrase
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-27 08:36 EDT by Justin Zygmont
Modified: 2010-06-28 09:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:19:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error on VC4 (187.46 KB, image/jpeg)
2009-08-10 14:44 EDT, Justin Zygmont
no flags Details

  None (edit)
Description Justin Zygmont 2009-06-27 08:36:15 EDT
Description of problem:

The installer hangs at the point when entering the passphrase for encrypted LVM. The keyboard and mouse become locked, hard reboot required.


Version-Release number of selected component (if applicable):

Anaconda in Fedora 11 (default)  Previous versions of Fedora always worked fine.


How reproducible:

always


Steps to Reproduce:
1. boot into install.img
2. Click "Next" at welcome to Fedora GUI
3. Enter passphrase for existing crypted LVM, watch the system freeze
  
Actual results:


Expected results:


Additional info:

VGA compatible controller: ATI Technologies Inc Rage Mobility M3 AGP 2x (rev 02)

I suspect this to be a possible cause, I tried to follow the instructions from bugs/common and enter nomodeset as a kernel parameter but nothing changed.
From the VC's I dont see anything to show a problem just before the freeze, but the last message to come up was something about setting AGP to 1x mode, sounds like the acceleration method.
Comment 1 Chris Lumens 2009-06-29 11:36:11 EDT
If the computer locks up so that keyboard and mouse no longer work, it's usually a kernel problem.  Reassigning.
Comment 2 Chuck Ebbert 2009-06-30 12:19:49 EDT
Can you try adding 'xdriver=vesa vga=792' to the boot options?
Comment 3 Justin Zygmont 2009-06-30 14:05:32 EDT
woah, great graphics.  Unfortunately, the same result.  everything is locked solid.


Here were my boot options from grub:

root (hd0,5)
kernel /f11/vmlinuz xdriver=vesa vga=792
initrd /f11/initrd.img


Hardware is a Dell inspirion laptop:

processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 8
model name	: Pentium III (Coppermine)
stepping	: 6
cpu MHz		: 700.000
cache size	: 256 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 2
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36 mmx fxsr sse up
bogomips	: 1403.18
clflush size	: 32
power management:


Video from the lspci command:

01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility M3 AGP 2x (rev 02)
Comment 4 Justin Zygmont 2009-07-05 08:12:47 EDT
Maybe its a module thats getting loaded when I enter the passphrase causing the hang?  I've tried everything I can think of, any idea what I can do next, or direct me to info on what more I can do?

Thanks, Justin
Comment 5 Justin Zygmont 2009-07-16 22:29:23 EDT
ping
Comment 6 Chuck Ebbert 2009-08-05 01:24:54 EDT
Try some of the other workarounds from here:
http://fedoraproject.org/wiki/KernelCommonProblems

And try "noagp" too.
Comment 7 Justin Zygmont 2009-08-10 14:44:33 EDT
Created attachment 356941 [details]
screenshot of error on VC4
Comment 8 Justin Zygmont 2009-08-10 14:50:55 EDT
hi, thanks for your help.  The kernel parameters you gave allowed me to see the error coming up in the virtual consoles, it seems anaconda runs out of ram and kills Xorg, freezing the install process hard.  So... I guess 384MB of ram is really the minimum now.  It doesn't looking like there's anything that can be done.  cantfix
Comment 9 Bug Zapper 2010-04-27 11:17:42 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2010-06-28 09:19:50 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.