Bug 508466 - (KMS, suspend) Laptop fails to suspend with radeon driver while KMS is enabled
Laptop fails to suspend with radeon driver while KMS is enabled
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-27 08:36 EDT by Nenad Mikša
Modified: 2009-11-06 12:18 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-06 12:18:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/dmesg from a working session (KMS disabled) (39.75 KB, text/plain)
2009-07-01 04:10 EDT, Nenad Mikša
no flags Details
Xorg.conf file (1.21 KB, text/plain)
2009-07-01 04:11 EDT, Nenad Mikša
no flags Details
Xorg.0.log from a working session (KMS disabled) (68.01 KB, text/plain)
2009-07-01 04:12 EDT, Nenad Mikša
no flags Details
/var/log/dmesg from a broken session (KMS enabled) (41.75 KB, text/plain)
2009-07-01 04:25 EDT, Nenad Mikša
no flags Details
Xorg.0.log from a broken session (KMS enabled) (40.17 KB, text/plain)
2009-07-01 04:26 EDT, Nenad Mikša
no flags Details
pm-suspend.log from a broken session (KMS enabled - suspend failed, resume impossible) (4.24 KB, text/plain)
2009-07-01 04:27 EDT, Nenad Mikša
no flags Details

  None (edit)
Description Nenad Mikša 2009-06-27 08:36:42 EDT
Description of problem:
While using radeon driver on Mobility Radeon X1600 graphic card (R500 based), with KMS enabled, laptop fails to suspend. pm-suspend.log states that everything is OK, but the graphic chip remains powered on and suspend is improper. After that, resuming is impossible and hard reboot is required.

Also, with KMS enabled, desktop composition doesn't work well - all windows just disappear and appear only under the cursor. Moreover, 'glxgears' renders gears, but instead of printing FPS, it prints some errors in the console.

If booting with 'nomodeset' kernel parameter, both suspend and desktop composition work fine (although enabling composition freezes X, but this bug is already reported elsewhere) and glxgears prints only information about current FPS rate.


Version-Release number of selected component (if applicable):


How reproducible:
Booting with KMS enabled and trying to suspend with 'pm-suspend' or via KDE Kickoff menu.


Steps to Reproduce:
1. Use laptop with Mobility Radeon X1600 graphics card.
2. Boot with KMS enabled.
3. Suspend the laptop.
  
Actual results:
Graphic chip remains powered on, and resuming is impossible.


Expected results:
Proper suspend is expected, as is with KMS disabled.


Additional info:
Comment 1 Matěj Cepl 2009-06-30 18:17:24 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Somehow it could be related to bug ati-xpress200M-fail, but not sure about that.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Matěj Cepl 2009-06-30 18:18:19 EDT
Sorry, that should be bug 498457 (bloody Bugzilla forget to link agian).
Comment 3 Nenad Mikša 2009-07-01 04:10:06 EDT
Created attachment 350065 [details]
/var/log/dmesg from a working session (KMS disabled)
Comment 4 Nenad Mikša 2009-07-01 04:11:13 EDT
Created attachment 350066 [details]
Xorg.conf file
Comment 5 Nenad Mikša 2009-07-01 04:12:32 EDT
Created attachment 350067 [details]
Xorg.0.log from a working session (KMS disabled)
Comment 6 Nenad Mikša 2009-07-01 04:25:24 EDT
Created attachment 350070 [details]
/var/log/dmesg from a broken session (KMS enabled)
Comment 7 Nenad Mikša 2009-07-01 04:26:42 EDT
Created attachment 350071 [details]
Xorg.0.log from a broken session (KMS enabled)
Comment 8 Nenad Mikša 2009-07-01 04:27:36 EDT
Created attachment 350072 [details]
pm-suspend.log from a broken session (KMS enabled - suspend failed, resume impossible)
Comment 9 Nenad Mikša 2009-07-01 04:32:16 EDT
I've attached all the files requested and I hope they will be of great use to developers.

Here are the errors that 'glxgears' prints while KMS is enabled:

[dodo@2nd-of-12 ~]$ glxgears                                             
CS section size missmatch start at (r300_cmdbuf.c,emit_cb_offset,254) 16 vs 7                                                                     
CS section end at (r300_cmdbuf.c,emit_cb_offset,264)                     
CS section size missmatch start at (r300_cmdbuf.c,emit_cb_offset,254) 16 vs 7
Comment 10 Nenad Mikša 2009-07-30 05:49:57 EDT
After updating kernel to 2.6.29.6-213.fc11.i586, desktop composition now works with KMS enabled and glxgears don't print any errors, but suspending to RAM still doesn't work (with KMS enabled).

With disabled KMS, STR works flawlessly.
Comment 11 Jerome Glisse 2009-08-06 09:58:08 EDT
You need to disable pm suspend quirk with kms, kms is doing everythings.
Comment 12 Nenad Mikša 2009-08-06 12:24:02 EDT
Sorry for being a noob, but how can I do that?
Comment 13 Nenad Mikša 2009-08-06 12:44:45 EDT
I tried running 'pm-suspend --quirk-none' but laptop still failed to suspend.
Comment 14 Nenad Mikša 2009-09-08 07:34:19 EDT
Yesterday I updated to kernel 2.6.30 and now STR works with KMS.

Kudos to all Fedora engineers! I hope one day I'll be as good as you are.
Comment 15 Nenad Mikša 2009-10-01 04:08:43 EDT
Updating kernel to 2.6.30.8 reintroduced the bug again.

With 2.6.30.5 everything works OK.
Comment 16 Nenad Mikša 2009-10-27 12:38:55 EDT
I've just updated to 2.6.30.9-90.

Suspend still fails... But I believe that the problem in 2.6.30.8 and 2.6.30.9 is in the audio driver, not the graphics driver, but how can I check that?
Comment 17 Matěj Cepl 2009-11-05 13:33:14 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 18 Nenad Mikša 2009-11-06 12:18:51 EST
Since I've had problems with downloading the nightly compose, I downloaded the Beta from http://download.fedoraproject.org/pub/fedora/linux/releases/test/12-Beta/Live/i686/F12-Beta-i686-Live-KDE.iso and tried it in a live session.

I tried to suspend the laptop from a live session and succeeded in one of two trials.

This means that this bug is fixed for me, as the failure to suspend in my second trial is another bug: it's the problem that every time a PowerDevil initiates a suspend action, it plays a sound, and if the computer suspends before the sound is played, some hardware remains powered on - same problem happens on F11, and it's easy to workaround it by simply disabling all suspend notifications from PowerDevil.

And I have one off-topic question: Does F12 use Gallium3D driver architecture for accelerating the Mobility Radeon X1600 card? I ask this because while in live session, I tried running glxgears, and got only 500 FPS in a non-composited environment (on F11 without composition and with KMS it's at least 1000 FPS, and without KMS it raises up to 1600 FPS), and less than 150 FPS with KWin's composition turned on (cca 500 FPS on F11 with Kwin effects and KMS enabled).

Note You need to log in before you can comment on or make changes to this bug.