Bug 508467 - compositing no longer works in F11 (worked in F10)
compositing no longer works in F11 (worked in F10)
Status: CLOSED DUPLICATE of bug 473440
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
R200
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-27 09:14 EDT by Éric Brunet
Modified: 2009-07-24 07:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 07:50:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/dmesg for a boot with modeset enabled (23.94 KB, text/plain)
2009-07-03 04:37 EDT, Éric Brunet
no flags Details
/var/log/Xorg.0.log with modeset enabled (41.57 KB, text/plain)
2009-07-03 04:38 EDT, Éric Brunet
no flags Details
/var/log/dmesg with modeset disabled (22.19 KB, text/plain)
2009-07-03 04:38 EDT, Éric Brunet
no flags Details
/var/log/Xorg.0.log with modeset disabled (60.50 KB, text/plain)
2009-07-03 04:39 EDT, Éric Brunet
no flags Details

  None (edit)
Description Éric Brunet 2009-06-27 09:14:13 EDT
I am using KDE, with compositing enabled in kwin. My video card is an old ATI

01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01) (prog-if 00 [VGA controller])
        Subsystem: PC Partner Limited Sapphire Radeon 9200                                                        
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-     
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-    
        Latency: 32 (2000ns min), Cache Line Size: 32 bytes                                                       
        Interrupt: pin A routed to IRQ 16                                                                         
        Region 0: Memory at d0000000 (32-bit, prefetchable) [size=128M]                                           
        Region 1: I/O ports at 9000 [size=256]                                                                    
        Region 2: Memory at e5000000 (32-bit, non-prefetchable) [size=64K]                                        
        [virtual] Expansion ROM at e4000000 [disabled] [size=128K]                                                
        Capabilities: <access denied>                                                                             
        Kernel modules: radeon, radeonfb                                                                          

With F10, Compositing was working fine (well I had an occasional flicker when opening a menu, but it was ok)

I upgraded to F11, and now it doesn't work anymore:

At the beginning, I have a simple konsole window on my desktop. Moving it around showed the expected effects. I launched a konqueror and only part of it would appear (for instance, the title bar and menu bar disappears. Then I type some text in the URL bar, and only trhe URL bar is visible. I move the window around by guessing where the menubar should be and by drag/dropping the window. Some part of konqueror appears and disappear in an incessant flicker.)

I tried to remove /etc/X11/xorg.conf (it didn't contain much anyway), nothing changed

I tried to add nomemset to the kernel parameters and rebooted. It changed something, in worse: on my desktop, the background did not appear anymore (it was all black), my konsole window was there and when I tried to move it, some strange graphical artefacts appeared and then X crashed. Here's the Backtrace

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x812d07b]
1: /usr/bin/X(xf86SigHandler+0x9e) [0x80c061e]
2: [0x110400]
3: /usr/lib/dri/r200_dri.so(radeonRefillCurrentDmaRegion+0x13d) [0x74ec2d]
4: /usr/lib/dri/r200_dri.so(radeonAllocDmaRegion+0xad) [0x74ed88]
5: /usr/lib/dri/r200_dri.so(rcommon_emit_vector+0x7e) [0x74ee6a]
6: /usr/lib/dri/r200_dri.so(r200EmitArrays+0x359) [0x744225]
7: /usr/lib/dri/r200_dri.so [0x73cbd0]
8: /usr/lib/dri/libdricore.so(_tnl_run_pipeline+0x128) [0x10563bf]
9: /usr/lib/dri/r200_dri.so [0x732dbb]
10: /usr/lib/dri/libdricore.so(_tnl_draw_prims+0xaf2) [0x1056f56]
11: /usr/lib/dri/libdricore.so(vbo_exec_vtx_flush+0x5c0) [0x104ee9b]
12: /usr/lib/dri/libdricore.so(vbo_exec_FlushVertices_internal+0x3f) [0x104bd65]
13: /usr/lib/dri/libdricore.so(vbo_exec_FlushVertices+0x36) [0x104bdd8]
14: /usr/lib/dri/libdricore.so(_mesa_set_scissor+0x51) [0x101de6d]
15: /usr/lib/dri/libdricore.so(_mesa_Scissor+0x74) [0x101df69]
16: /usr/lib/xorg/modules/extensions//libglx.so [0xa818dd]
17: /usr/lib/xorg/modules/extensions//libglx.so [0xaabb94]
18: /usr/lib/xorg/modules/extensions//libglx.so [0xab0340]
19: /usr/bin/X(Dispatch+0x347) [0x80864d7]
20: /usr/bin/X(main+0x395) [0x806baf5]
21: /lib/libc.so.6(__libc_start_main+0xe6) [0x7eea66]
22: /usr/bin/X [0x806afa1]

Fatal server error:
Caught signal 11.  Server aborting

I then disabled compositing in kwin in order to have a usable system (seems ok so far...Even glxgears works) but I would love to enable it again: it worked in F10!

System is uptodate. Relevant packages versions:
kernel-2.6.29.5-191.fc11.i586
xorg-x11-server-Xorg-1.6.1.901-1.fc11.i586
xorg-x11-drv-ati-6.12.2-14.fc11.i586
kdebase-4.2.4-2.fc11.i586
Comment 1 Matěj Cepl 2009-06-30 18:31:48 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Éric Brunet 2009-07-03 04:37:26 EDT
Created attachment 350392 [details]
/var/log/dmesg for a boot with modeset enabled
Comment 3 Éric Brunet 2009-07-03 04:38:10 EDT
Created attachment 350393 [details]
/var/log/Xorg.0.log with modeset enabled
Comment 4 Éric Brunet 2009-07-03 04:38:48 EDT
Created attachment 350394 [details]
/var/log/dmesg with modeset disabled
Comment 5 Éric Brunet 2009-07-03 04:39:33 EDT
Created attachment 350396 [details]
/var/log/Xorg.0.log with modeset disabled
Comment 6 Éric Brunet 2009-07-03 04:50:46 EDT
Here's what I did. I booted the system with compositing disabled. Everything works fine. I copied the files /var/log/dmesg and /var/log/Xorg.0.log. Then, I
turned compositing on from kcontrol, observed the effects and copy the new versions of the same file to look at what is added. I did this twice, once with modeset enabled and once with modeset disabled.

With modeset disabled
=====================

When I turn compositing on, the screen becomes all blue, with only the mouse
cursor visible. I can move the mouse around, but the keyboard does not respond (even CapsLock and NumLock do not lit the LEDs). The machine is still up and I can log in via ssh. Plenty of stuff is added in Xorg.0.log (I marked in the file the limit between before and after switching compositing on) but nothing more appeard in /var/log/dmesg. However, the dmesg command outputs 2400 lines of
        [drm:drm_lock_take] *ERROR* 3 holds heavyweight lock


With modeset enabled
====================

When I turn compositing on, the windows disappear (I can still see the background picture). When I move the mouse around, part of the windows appear under the mouse (a button, a menubar, a window title, etc.) and other parts far from the mouse cursor disappear. The computer seems otherwise to be running fine: if I can guess where the titlebar is, I can click on it and drag and drop the window, with all the woobly effects. (The window is fully visible during the drag and drop.) Again, many lines added in Xorg.0.log (see attachment), nothind added in /var/log/dmesg, but this time nothing special in the output of the dmesg command. Unselecting compositing gives me back a fully working system (without the effects, of course)

Again, let me emphasize that compositing was working nicely in F10.
Comment 7 Matěj Cepl 2009-07-24 07:50:50 EDT
Looks like duplicate of bug 473440 to me. Closing

*** This bug has been marked as a duplicate of bug 473440 ***

Note You need to log in before you can comment on or make changes to this bug.